Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I had tried to deploy mysql and i had this error:

agent-state-info: container failed to start

Outputs from log as following:

Line 47: machine-0: 2014-08-14 02:02:30 INFO juju.state.api apiclient.go:250 error dialing "wss://localhost:17070/": websocket.Dial wss://localhost:17070/: dial tcp connection refused
Line 48: machine-0: 2014-08-14 02:02:30 ERROR juju.worker runner.go:218 exited "api": unable to connect to "wss://localhost:17070/"
ERROR juju.container.lxc lxc.go:243 container failed to start: container failed to start
Line 438: machine-0: 2014-08-14 02:04:44 ERROR juju.provisioner provisioner_task.go:421 cannot start instance for machine "1": container failed to start

How do I resolved this issue?

Any inputs are greatly appreciate.

share|improve this question
I notice that only trusty charms are able to work. All other charms running on precise was not able to deploy. Anyone can confirm this? I am running ubuntu 14.04. – Lian Junxiang Aug 14 '14 at 15:39
Is this with the local provider? Also, can you give the commands you used? – thumper Aug 15 '14 at 3:13
yes i tried deploying with the local lxc. juju deploy owncloud --show-log --debug – Lian Junxiang Aug 15 '14 at 8:43
Close voters: How is this not reproducible? – Seth Jan 16 at 20:45

1 Answer 1

Trusty Charms only work on Trusty systems (Ubuntu 14.04). Precise Charms only work on Precise systems (Ubuntu 12.04). You're using LXC as provider on a 14.04 machine. Because LXC isn't complete virtualisation, LXC will not be able to create a precise machine on a Trusty host. This is the error you are getting. Juju tries to provision a new precise machine, but it fails, because it can only make Trusty machines on a Trusty host.

You can specify the series in the deploy command. The following command will deploy the trusty version of mysql.

juju deploy cs:trusty/mysql

If you don't specify which series (OS version), Juju uses the default-series. The default-series can be specified in environments.yaml for a new environment:

default-series: trusty

Or use the following command to change the default-series of an existing, already bootstrapped environment:

juju set-env "default-series=trusty"


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.