Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to edit my splash screen but its really annoying to restart the computer everytime just to find out it doesn't even work. i read on an article that I can do a virtual machine via ssh but I have no idea how to do that. I installed ubuntu in VirtualBox yesterday now installing sudo apt-get install openssh-server openssh-client on it. Now I am supposed to access the machine as root and test splash on tty1, and I have no idea how to do that. I tried searching around but there isn't a lot of information regarding Plymouth testing on the web.

Any help appreciated, thanks.

share|improve this question
1  
You cannot test plymouth in VirtualBox because the display driver does not create a special device (/dev/dri/card0 to be exact), neither is it possible to display such a graphical thing in a terminal using SSH. –  Lekensteyn Jun 29 '11 at 9:28
    
ohh i didn't know that, thanks. so what is ssh used for what are the reasons people use it? –  Vitaly Jun 29 '11 at 9:43
    
SSH provides a console in which commands can be entered. Although SSH can forward GUI (it's called X Forwarding), SSH is mainly used for entering commands directly. See also What is the terminal? –  Lekensteyn Jun 29 '11 at 9:55
add comment

1 Answer

up vote 3 down vote accepted

You don't need VirtualBox for that. You can test themes within a session.

  • Install the package plymouth-x11
  • Run sudo plymouthd ; sudo plymouth --show-splash ; sleep 10 ; sudo killall plymouthd

This will show you how your theme would look like on two screens (actually a simulation of multi-monitor setups) for 10 seconds. You can add the different actions you want to test (see plymouth --help) between the --show-splash and sleep command.

share|improve this answer
    
i tried this command last time and it just loged me out, looks like i was missing the plymouth-x11 package. thanx it worked this time but the window was blank. ill have to reinstall the splash i guess. –  Vitaly Jun 29 '11 at 9:44
    
ya it works now although I get 2 screens and in the splah the logo and spinning arrows are out of not aligned. and i didnt see the progress bar. Am I doing something wrong? –  Vitaly Jun 29 '11 at 10:12
    
I don't know what theme you are testing. There's no progress bar or spinning arrows in Ubuntu's default theme. –  htorque Jun 29 '11 at 10:22
    
gnome-look.org/content/show.php/… this is the splash I am trying to imporve to my liking at the momment the only thing i changed in the script file was to slow down the spinning of the logo. –  Vitaly Jun 29 '11 at 10:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.