Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Internal Audio Hardware card and my Laptop (Lenevo IdeaPad) presents a single slot as a combo Microphone and headphone jack.

On Windows, I attach my ipod headphone to jack and speak directly to my computer. I assume there is a microphone which is listening to my voice and I can communicate two-way. On Ubuntu, the microphone always seem to be listening to random noise. So any input by speaking to the computer is not possible. What could be the reason and how do I troubleshoot this?

share|improve this question
add comment

3 Answers

I have a similar laptop and had a similar problem. I spent on total over 10 hours from basic troubleshooting, asking stuff on forums, googling, changing alsa packages to beta versions -- basicly everything I could imagine to try.

I (and some helpers) arrived to the conclusion that the hardware just is not supported. What was essentially the problem was that the built in laptop mic would stay active, and the headset mic would not activate at all. Dual booting to windows showed that there was no hardware problem since it worked perfectly in Win 7.

I ended up buying a cheap USB headset and it's working perfectly. IF however you succeed to get it work, please answer to your own question here so I can see if the same solution would work. Good luck!

share|improve this answer
    
Thanks for the response, red. I think I would be adopting the same solution as you. I shall also follow up with a bug report to Ubuntu. –  Senthil Kumaran Jun 29 '11 at 14:46
add comment

Sounds like this thread will help you get on the right path to trouble shooting the issue microphone problem and How do I install my microphone?

share|improve this answer
    
I have tried all the basic troubleshooting. Does not help. –  Senthil Kumaran Jun 29 '11 at 6:31
add comment

Try this: add the following line to any file in /etc/modprobe.d/

options snd-hda-intel model="olpc-xo-1_5"

Source: https://bugs.launchpad.net/ubuntu/+source/linux-backports-modules-2.6.32/+bug/549289

share|improve this answer
    
geoffrey, tried that suggest and it still does not work. I am facing the same problem of hearing disturbance via input. –  Senthil Kumaran Jul 1 '11 at 4:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.