Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded my netbook thus: Lucid -> Maverick -> Natty. (I skipped Maverick other than as an upgrade step due to issues with Unity.)

Now, I seem to be stuck with something that looks like Emerald but apparently isn't (see note below). Compiz is running, as is gtk-window-decorator, but my title bars aren't following Ubuntu's theme. I was using the Ambiance theme with no problems until the upgrade to Natty.

Here's a screenshot: Emerald theme

How can I get the default theme?

Note: I never installed Emerald, and as far as I can tell it isn't installed. There's no running process containing the string emerald. So I'm not sure where gtk-window-decorator is getting its configuration from.

Edit

Following htorque's very reasonable suggestion to run unity --reset made matters worse. Now, after logging out/in, most of my theme-related stuff is gone entirely and can't be changed (clicking on the themes in the dialog changes the title bar/scrollbar color but nothing else). Here's a screenshot of the current situation:

Screenshot of the new situation

share|improve this question
    
have you tried uninstalling Emerald? –  Christopher Kyle Horton Jun 29 '11 at 3:29
    
@Warrioring64: I can't find a package for emerald. As far as I can tell, emerald isn't running. I'm updating my question accordingly. –  Scott Severance Jun 29 '11 at 4:17

2 Answers 2

up vote 3 down vote accepted

This doesn't seem to be Emerald, but an undecorated Metacity.

I worked this out using Ubuntu Tweak, since I forgot where the option was in gconf-editor.

If you haven't installed it yet, you can do so by:

sudo add-apt-repository ppa:tualatrix/ppa && sudo apt-get update

sudo apt-get install ubuntu-tweak

Once installed, open it up, and head to Window Manager Settings, under the Desktop section. Scroll down, and the option for "Use Metacity window theme" under Window Effects should be unchecked in your present condition. Check it, and it should bring up the correct theme. If not, restart Compiz.

Hope that works! :)

share|improve this answer
    
Worked like a charm! Thanks! I just hit the "reset to default" button on everything in that section. –  Scott Severance Jun 29 '11 at 12:28

Try running

unity --reset

This should reset your Compiz profile to Unity's defaults (e.g., the window decorator should be /usr/bin/compiz-decorator).

share|improve this answer
    
I don't know what's wrong, because unity --reset only made things worse. See update above. –  Scott Severance Jun 29 '11 at 10:32
    
Would have been nice to see the decoration go away. :-( Anyways. Do you have anything added to your ~/.gtkrc-2.0 or ~/.gtkrc file? Have any theme data in ~/.themes? What's the output of gconftool-2 --get /apps/metacity/general/theme? –  htorque Jun 29 '11 at 10:47
    
~/.gtkrc* doesn't exist. I renamed ~/.themes. Additionally, I reinstalled all the Unity- and theme-related stuff I could find. Upon rebooting, the situation is back to my original problem. GConf reports that the current theme is Ambiance. Changing the theme to Clearlooks results in the appearance as shown in my second screenshot. Changing it to Ambiance results in everything being correct except the titlbars (as in the first screenshot). –  Scott Severance Jun 29 '11 at 11:28
    
Further testing reveals that changing themes works as expected, except that the titlebar remains the same, only changing color and font weight. And it's a terrible titlebar design to use! –  Scott Severance Jun 29 '11 at 11:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.