Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I upgraded a Dell Inspiron E1505 from 10.04 to Natty (11.04) two days ago. I wanted to change properties in my Unity toolbar but when I opened gconf-editor > desktop I found that there was no unity-2d folder.

What IS under gconf-editor < desktop is gnome, ibus and pgp. What do I do now?

share|improve this question
As you can see in my screenshot, I did not find a unity-2d folder in my gconf either: !missing folder I tried your suggestion but still the same. – user21890 Jul 19 '11 at 20:21

Make sure you have Unity 2D installed. You can check by running:

dpkg -l | grep "ii" | sed -e 's/^ii\ \ //g' -e 's/\ .*$//g'

If you have Unity 3D installed, it will return unity only. If you have Unity 2D installed, it will return unity-2d. If you have both installed, it will return both.

If unity-2d is installed and it still doesn't show up in gconf-editor, try running:

gconftool-2 --shutdown

and then log out and log back in.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.