Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to resize my partitions, to increase the area for my install of Ubuntu 14.04. I'd like to regain use of that partition, which I was unable to get back into after doing a fresh install of Windows XP on another partition. I'm currently using Ubuntu trial via a boot repair USB.

I unswapped the linux-swap so I could move the partitions, but Gparted comes back with error messages each time I try to resize something. (I can't use a screenshot because I lack enough of a reputation here to upload images.)

In Gparted the partitions are:

/dev/sda,   1ntfs,         9.77GB (3.7GB used);
unallocated,             34.93GB;
/dev/sda2,   extended,    29.83GB;
/dev/sda5,   ext4,        27.83GB (11.8GB used);
/dev/sda6,   linux-swap,   2GB.

I assume the ntfs part is my Windows XP reinstall and the ext4 part is my Ubuntu 14.04 install. I've been reading through answers here and on Gparted but am not getting anywhere.

Backstory: I had Windows XP but it stopped working, then I installed Ubuntu 14.04 alongside it (which has been behaving in faulty ways, not loading properly etc). I re-installed Windows XP on a reduced partition of ~10GB. Since the Win reinstall I'm unable to start the Ubuntu OS, so am using Ubuntu via the trial option on a boot repair USB... My files are backed up.

(I'm on a Dell Latitude 640m laptop.)

This is the error message when I tried to expand the extended (empty, 29.83GB) partition into the unallocated partition (this was too long to be allowed in a comment). Note that there are no lock keys anywhere and everything is unmounted etc: GParted 0.12.1 --enable-libparted-dmraid

Libparted 2.3
Move /dev/sda2 to the left and grow it from 29.83 GiB to 64.76 GiB  00:00:00    ( ERROR )

calibrate /dev/sda2  00:00:00    ( SUCCESS )

path: /dev/sda2
start: 93,745,150
end: 156,301,311
size: 62,556,162 (29.83 GiB)
move partition to the left and grow it from 29.83 GiB to 64.76 GiB  00:00:00    ( ERROR )

old start: 93,745,150
old end: 156,301,311
old size: 62,556,162 (29.83 GiB)
requested start: 20,484,096
requested end: 156,299,263
requested size: 135,815,168 (64.76 GiB)
libparted messages    ( INFO )

Unable to satisfy all constraints on the partition.
Can't have overlapping partitions.

========================================
share|improve this question
1  
Since GParted runs under the root user the gparted_details.htm log file is by default saved under the "/root" directory. If you are running from Live media then the file system exists in RAM only. Hence you must copy the file to more permanent storage, such as a USB flash drive, before you shutdown the live environment. Alternatively you can post directly to this forum while running in the live environment. –  Curtis Gedak Aug 12 at 20:49
    
I wasn't able to find or access the saved error details, but will try to copy them directly here as you suggest - how do I find them. I don't have a spare USB to save them to. I want to expand the ext4 partition (I assume this is the Ubuntu install) to use up all the unallocated space to the left of it. Do I have to re-size the extended partition first, or can I do them both at the same time? And is this wise? –  Sky Aug 12 at 23:46
    
@user314203 you may do both at the same time. –  Hi-Angel Aug 13 at 2:39
    
I've added the error message in my question. –  Sky Aug 13 at 22:10
    
@user314203, updated my answer. –  Hi-Angel Aug 14 at 2:47

1 Answer 1

up vote 0 down vote accepted

You may upload a screenshot to some service, and rest here a link. Without an error description it is hard to say what you had encountered.

About your second part of a question, if I properly understood you, the Windows just erased an old loader. It's not a big problem, unless you may load from USB stick. As the Windows doesn't recognizes an alien bootloaders, it is so often occured thing, that the Canonical(a company that develops Ubuntu) even wrote a how-to on how to fix it.

UPD: I am agree with @ Curtis's hypothesis, but I think that you may try to solve this other way, than trying to find latest version, or compiling it from a sources: try to install KDE Partition Manager, and see, what it does (sudo apt-get install partitionmanager).

share|improve this answer
    
Thanks, I used boot repair off my live Ubuntu USB and did the 'recommended repair', then my previous Ubuntu install loaded fine. I don't understand how to upload a screenshot to a service - what service? I had 'saved details' when the Gparted errors occurred but then couldn't open the root folder to copy the information. –  Sky Aug 12 at 23:33
    
This website wouldn't allow me to link to a screenshot in freeimagehosting.net, so I don't know how to do that. –  Sky Aug 13 at 1:40
    
@user314203, so, can you just put in comments a link to freeimagehosting.net? Or is it somehow blocks your comment? And why can't you open a root folder -- perhaps you just need a root rights? ;) (you may enter sudo -s in terminal to acquire it) –  Hi-Angel Aug 13 at 2:15
1  
I suspect that you encountered Bug 686668 - Growing logical partition overlaps end of extended partition. Many bugs have been fixed since GParted 0.12.1 was released. I highly recommend that you retry the operation using the latest version of GParted (currently 0.19.1). One way to do this is by booting from media containing GParted Live. –  Curtis Gedak Aug 14 at 0:52
1  
I bought a new USB and used Unetbootin to make a bootable USB from the latest version of GParted that Curtis recommended, 0.19.1 (I tried to use tuxboot to make the USB but couldn't figure out how to install it). GParted was simple and easy to use (though I found the keyboard layout options confusing); no problems booting afterwards. Thanks very much Curtis and Angel for your help (and Curtis for your work on GParted). Now onto the rest of the faults on my Ubuntu system. Miss the simplicity of Windows sometimes... –  Sky Aug 16 at 0:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.