Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have only the base KDE installed (sudo apt-get install plasma-desktop), not the entire kubuntu-desktop. Unfortunately GTK apps have the fugly Raleigh theme. I've installed QtCurve with sudo apt-get install qtcurve, but the GTK apps still have Raleigh theme. I assume I have to select the QtCurve theme somehow.


@13east has posted a picture of the settings dialog in his answer below. Unfortunately the GTK+ appearance is the only tab that is missing from my Settings Dialog. I assume this is because I've installed only plasma-desktop instead of the entire kubuntu-desktop. Is there a way to manually set the theme, perhaps by editing some configuration files?

share|improve this question
    
If you've added the kubuntu-desktop from w/in an gnome installation, I'd recommend doing a fresh installation of Kubuntu on your machine if you can spare the time and have your data backed up to do so. It will be better for you if you have a clean install on you machine instead of having a hybrid-mix of gnome/gtk and kde/qt dependencies, as it will bring you a lot more problems like this in the future. –  13east Jun 29 '11 at 16:19
    
IIRC there's some package named kde-gtk , which is why you don't have the GTK config tab –  warl0ck Jun 3 '12 at 13:16

4 Answers 4

If you open the "System Settings" app, there's an icon in the top row for something like "application settings" (I think it's second or third from the left in the top row--I don't have KDE available at the moment). If you click on that icon you'll see a dialogue with a few options in the left-hand panel. One of them is to set the theme for GTK applications. You should just be able to select qtcurve from the drop-down menu in the right-hand pane under that tab.

share|improve this answer
1  
Hi, thanks for answering. This tab is missing. See above, I've edited my question with more info. –  sashoalm Jun 29 '11 at 9:25

IIRC there's some package named kde-gtk , which is why you don't have the GTK config tab.

Also , you should edit ~/.gtkrc-2.0 manually if things above failed to function:

include "/usr/share/themes/QtCurve/gtk-2.0/gtkrc"

For GTK3 , i'm not sure if it's supported.

share|improve this answer
1  
The package is called kde-config-gtk-style. –  Haakon Apr 24 at 7:49

System Settings -> Application Appearance -> GTK+ Appearance -> Widget Style

enter image description here

share|improve this answer
    
Hi, thanks for answering. This tab is missing. See above, I've edited my question with more info. –  sashoalm Jun 29 '11 at 9:24

Install the kde-config-gtk package, and you'll get the missing sub-applet. OTOH, trying to use this still doesn't change the GTK theme, but I'm using 12.04 beta 1.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.