Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

My keyboard doesn't have Right-Ctrl key. Does anyone know how can i change the behaviour of my Insert key to do the operation of Right-Ctrl key?

i use this:

How do I remap certain keys or devices?

and then

xmodmap -e "keycode 118 = Control_L"

this change Inser behavior but not same as Ctrl, now insert do anything!

share|improve this question

marked as duplicate by Tim, Lucio, Glutanimate, Eric Carvalho, Eliah Kagan Aug 11 at 15:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

Click on System > Preferences > Keyboard

This will open the Keyboard preferences. In “Layout” tab find “options…” then locate “Ctrl key position”

select “Swap Ctrl and Insert”

or also you can select “Make Insert an additional Ctrl”

this also work for virtual consoles

From the bug report on launchpad: key remaps no longer work:

First Edit /etc/default/console-setup and add an X11 style caps lock modification:

$ diff -U0 /etc/default/{console-setup.orig,console-setup}
--- /etc/default/console-setup.orig     2009-02-09 03:05:27.000000000 -0500
+++ /etc/default/console-setup  2009-02-09 04:11:20.000000000 -0500
@@ -40 +40 @@
-XKBOPTIONS=""
+XKBOPTIONS="ctrl:swapcaps"

you can do “ctrl:nocaps” instead if you want to two control keys.

Second Trick dpkg into integrating your changes:

$ sudo dpkg-reconfigure console-setup

and choose all the defaults.

On Ubuntu Raring Ringtail (13.04) (and possibly on other versions), it is posible to simply edit the file /etc/default/keyboard, modify the XKBOPTIONS setting (for example XKBOPTIONS=“ctrl:nocaps”) and do:

$ sudo dpkg-reconfigure keyboard-configuration

Which will apply the change to both virtual consoles and X.org.

I think the first part would be yours since you are most probably using 14.04

share|improve this answer
    
Could you add a link to the bug report? –  Volker Siegel Aug 10 at 6:18
    
at xubuntu there is no "Ctrl key position"'."ctrl:swapcaps" it seems change Capslock. –  hadi aj Aug 10 at 6:29
    
sorry just put i insert instead –  pranay Aug 10 at 8:53
    
you could also sewe if changing keyboard layouts works, maybe english UK or English Australia has insert key at the place of ctrl –  pranay Aug 10 at 8:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.