Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've used "Mouse Preferences" window to set mouse pointer acceleration and sensitivity sliders to their maximums, but I am still not satisfied with how fast does mouse pointer move (I've got a very big display). Can I accelerate it over?

share|improve this question
    
I've been trying to do the opposite: decrease the sensitivity below the minimum. Have you had any luck with your attempts? –  Malabarba Oct 20 '10 at 15:53
    
No, I hadn't. I had to adapt myself :-( –  Ivan Oct 20 '10 at 16:22

2 Answers 2

I'm not really sure what the range of the mouse acceleration sliders are, but you can easily change this manually by using xset.

Try something like xset m 100 5, that makes it go very fast for me.

The syntax of the command is:

xset m <pixels to move when going fast> <pixels threshold before moving fast>

To make the changes stick, put them in your ~/.xinitrc

share|improve this answer
    
Does not help. Even after "xset m 1000 3" I can't feel any difference. I use Ubuntu 10.10 with Logitech M-BT58 USB mouse. I also have built-in PS/2 touchpad in my laptop, but it does not get much faster also. –  Ivan Oct 3 '10 at 2:36
    
@Ivan: I'm running Kubuntu 10.10 so I assumed it would be the same for Ubuntu. I can't really figure out why it would be any different for Ubuntu though. Can you try xset m 50 1 instead? I'm not sure where the limits are but 1000 3 doesn't do much for me either. –  Wolph Oct 3 '10 at 2:46
    
@Ivan - it may be getting overwritten by gnome-settings-daemon or similar. You can use xset q before and after to see if it is having any effect. Also, do you have more than one pointing device (mouse, trackpad, ball) attached to your computer ? –  koushik Oct 6 '10 at 11:35

I do not know if this is the right approach, but changing the AccelerationProfile from 0 to 6 and setting the VelocityScale to 10 you can get a really quick pointer. Much faster than if you change it in "Mouse Preferences". Here's how to do it:

First, you need to find your mouse ID and ProductName :

xinput list
...
 Logitech USB Optical Mouse                 id=11   [slave  pointer  (2)]
...

Now you can set the AccelerationProfile to 6 with this command :

xinput set-prop 11 "Device Accel Profile" 6
# 11 = DEVICE_ID
# 6 = linear (more speed, more acceleration)

Then you set the VelocityScale to what suits you. (1 to 10) (Higher = Faster):

xinput set-prop 11 "Device Accel Velocity Scaling" 5

If the above solution works for you, you can make it persistent by editing your xorg.conf (/etc/X11/xorg.conf). Add this section at the end of the file.

Section "InputClass"
   Identifier      "Logitech"                   # Whatever you want.
   MatchProduct    "Logitech USB Optical Mouse" # ProductName from xinput list.
   Option          "AccelerationProfile" "6"
   Option          "VelocityScale" "5"
EndSection

Once you reboot, you should have the same result as with the xinput command.

Let me know if it helps.

*** Tested with Ubuntu 10.10 ***

References :

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.