Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ok, I have searched for some time in earnest for an answer to this question. I have a Beagleboard which has Ubuntu 10.10 Minimal install for Arm running on it.

With the default install, minimal tools, no GUI, I am unable to connect to my wireless network. The name of my network is "MYNAME NETWORK". Using a text editor to edit /etc/network/interfaces I can not seem to connect at all.

As an experiment, I connected to a friends network, which has a one word name "dystek",and was able to connect with Zero issues, and update and install a full GUI for ubuntu Arm.

The problem is that I don't want a full blown gui on the beagleboard, just a minimal install of ubuntu with CLI is all I need or want.

Is there anyway to connect to my wireless network via editing the /etc/network/interfaces file. Surely there is... I just don't know how.

Right now my interfaces file looks like this:

auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet static
address 192.168.1.200
netmask 255.255.255.0
gateway 192.168.1.1
wireless-essid BARRETT NETWORK
wireless-key 46456xxxxxxxx

Any help would be appreciated.

share|improve this question
    
did James' suggestion in the comment to my answer help? –  jozzas Jun 30 '11 at 6:41

1 Answer 1

From here:

Add the name (ssid) for the network you want to create/join. Use single quotes if there is a space in the name.

So you could try:

wireless-essid 'BARRETT NETWORK'

Another alternative is to specify the MAC address of the router/gateway, instead of the name. This is called the bssid.

wireless-bssid FFFFFFFFFFFF

You would replace the essid line with a bssid line containing the MAC address of the router (it should be printed on the bottom of it, or can be found with sudo iwlist scanning under 'Address').


Edit: From James' comments below, try replacing the wireless-essid and wireless-key lines with the following, as you are using WPA. Your passphrase also needs to be in hex. There are online tools for converting your passphrase to hex.

wpa-ssid 'BARRETT NETWORK'
wpa-psk 46456xxxxxxxx
share|improve this answer
    
I had tried the single quotes, thinking that I had it right, but I had left the slash in, () not sure where i heard that it needed that. 'Barrett Network' does not work. –  grinan Jun 28 '11 at 2:07
1  
Now trying the mac address as bssid, no quotes, does not work either. –  grinan Jun 28 '11 at 2:12
1  
The configuration you've quoted is for a network protected by WEP, which is a bit uncommon these days. If the network is instead using WPA, then that is more likely to be the reason you can't connect rather than an incorrect network name. If that's the case then you should probably be using the wpa-ssid and wpa-psk options instead of wireless-essid and wireless-key. –  James Henstridge Jun 28 '11 at 2:23
    
@grinan James makes a good point, are you sure your network is using WEP? If not, try the wpa commands he listed. –  jozzas Jun 28 '11 at 2:55
1  
as a follow up to this, I am definitely on a wep connection, but the main problem was using a passphrase instead of a hex key. Once I corrected this, today, finally got it working correctly. –  grinan Jul 9 '11 at 3:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.