Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Thanks for any help you can provide I seem to be stuck on this error for hours.

I am trying to setup a percona 5.6 cluster. I have installed on 14.04 these packages and removed any trace of mysql.

percona-xtradb-cluster-server-5.6 percona-xtradb-cluster-client-5.6

I have then tried to bootstrap a cluster. This works correctly on 192.168.1.2

wsrep_provider=/usr/lib/libgalera_smm.so
#wsrep_cluster_address=gcomm://192.168.1.2,192.168.1.3
wsrep_cluster_address=gcomm://
wsrep_node_address=192.168.1.2
default_storage_engine=InnoDB
wsrep_cluster_name=sociabledata
wsrep_sst_auth="sstuser:<password>"
binlog_format=ROW
innodb_locks_unsafe_for_binlog=1
innodb_autoinc_lock_mode=2
wsrep_sst_method=xtrabackup

I then setup .3

wsrep_provider=/usr/lib/libgalera_smm.so
wsrep_cluster_address=gcomm://192.168.1.2,192.168.1.3
wsrep_node_address=192.168.1.3
default_storage_engine=InnoDB
wsrep_cluster_name=sociabledata
wsrep_sst_auth=sstuser:<some pass>
binlog_format=ROW
innodb_locks_unsafe_for_binlog=1
innodb_autoinc_lock_mode=2
wsrep_sst_method=xtrabackup

Watching error log for .2 does not show anything for serious errors other then .3 trying to connect, and disconnecting.. essentially is what I am understanding of it.

.3 shows me this error

2014-08-07 23:57:56 19987 [Note] WSREP: Running: 'wsrep_sst_xtrabackup --role 'joiner' --address '192.168.1.3' --auth 'sstuser:s3cretPass' --datadir '/var/lib/mysql/'     --defaults-file '/etc/mysql/my.cnf' --parent '19987'  '' '
2014-08-07 23:57:56 19987 [ERROR] WSREP: Failed to read 'ready <addr>' from: wsrep_sst_xtrabackup --role 'joiner' --address '192.168.1.3' --auth 'sstuser:<password>' --datadir '/var/lib/mysql/' --defaults-file '/etc/mysql/my.cnf' --parent '19987'  ''
    Read: '(null)'
2014-08-07 23:57:56 19987 [ERROR] WSREP: Process completed with error: wsrep_sst_xtrabackup --role 'joiner' --address '192.168.1.3' --auth 'sstuser:<password>' --datadir '/var/lib/mysql/' --defaults-file '/etc/mysql/my.cnf' --parent '19987'  '' : 2 (No such file or directory)

2014-08-07 23:57:56 19987 [ERROR] WSREP: Failed to prepare for 'xtrabackup' SST. Unrecoverable. 2014-08-07 23:57:56 19987 [ERROR] Aborting

Yes I have confirmed I can mysql -u sstuser -p and works from .2

I am using service mysql start in all cases.

I would tag this percona but i do not have the reputation :(

Should also note on .3 if I run the command wsrep_sst_xtrabackup --role 'joiner' --address '192.168.1.3' --auth 'sstuser:' --datadir '/var/lib/mysql/' --defaults-file '/etc/mysql/my.cnf' --parent '19987' ''

It gives no error, and seems to be waiting for something.

I am running Ubuntu 14.04 server.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.