Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I ran these commands:

juju generate-config
juju switch manual

Then I edited the environment file to add the host address.

Then:

juju bootstrap
juju deploy --to 0 juju-gui

And I got the error message:

ERROR cannot assign unit "juju-gui/0" to machine 0: series does not match

I got similar errors trying to deploy mysql to another machine after add-machine but I guess the answer to the above question can solve the other case as well.

share|improve this question

2 Answers 2

What is your host series? Precise? Trusty? It's likely that the default series does not match so it's trying to deploy the incorrect charm type.

Try: juju deploy --to 0 cs:precise/juju-gui if it's precise or "cs:trusty/juju-gui" if it's trusty.

share|improve this answer
    
I've received the same problem –  Riccardo Magrini Sep 12 at 10:09

Three things to check:

  1. Is there a default-series setting in your $HOME/.juju/environments.yaml for your environment named "manual"? If not, I think "precise" is still the default.
  2. Immediately after juju bootstrap, run juju status and see what's the machine 0's "series" (e.g. "series: trusty"). The charm you're trying to deploy must match that series.
  3. After running juju deploy juju-gui --to 0, you'll see a message like Added charm "cs:precise/juju-gui-98" to the environment. If the series on the machine did not match the charm series, you'll also get an error like ERROR cannot assign unit "juju-gui/0" to machine 0: series does not match.

So, you either deploy with explicit series, e.g. juju deploy cs:trusty/juju-gui --to 0, specifying a series matching machine 0's series; or alternatively, set "default-series: trusty" before bootstrap.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.