Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was trying to apply this "What should I do to run after I have successfully installed touchegg on Ubuntu 12.10?" than this happened at step3.2 when trying to rebuild the .deb

/tmp/unity/unity-7.2.2+14.04.20140714/plugins/unityshell/src/unityshell.cpp:4008:4: error: invalid preprocessing directive #gestures_sub_launcher_
   #gestures_sub_launcher_.reset(new nux::GesturesSubscription);
    ^
/tmp/unity/unity-7.2.2+14.04.20140714/plugins/unityshell/src/unityshell.cpp:4009:4: error: invalid preprocessing directive #gestures_sub_launcher_
   #gestures_sub_launcher_->SetGestureClasses(nux::DRAG_GESTURE);
    ^
/tmp/unity/unity-7.2.2+14.04.20140714/plugins/unityshell/src/unityshell.cpp:4010:4: error: invalid preprocessing directive #gestures_sub_launcher_
   #gestures_sub_launcher_->SetNumTouches(4);
    ^
/tmp/unity/unity-7.2.2+14.04.20140714/plugins/unityshell/src/unityshell.cpp:4011:4: error: invalid preprocessing directive #gestures_sub_launcher_
   #gestures_sub_launcher_->SetWindowId(GDK_ROOT_WINDOW());
    ^
/tmp/unity/unity-7.2.2+14.04.20140714/plugins/unityshell/src/unityshell.cpp:4012:4: error: invalid preprocessing directive #gestures_sub_launcher_
   #gestures_sub_launcher_->Activate();
    ^
/tmp/unity/unity-7.2.2+14.04.20140714/plugins/unityshell/src/unityshell.cpp:4014:4: error: invalid preprocessing directive #gestures_sub_dash_
   #gestures_sub_dash_.reset(new nux::GesturesSubscription);
    ^
/tmp/unity/unity-7.2.2+14.04.20140714/plugins/unityshell/src/unityshell.cpp:4015:4: error: invalid preprocessing directive #gestures_sub_dash_
   #gestures_sub_dash_->SetGestureClasses(nux::TAP_GESTURE);
    ^
/tmp/unity/unity-7.2.2+14.04.20140714/plugins/unityshell/src/unityshell.cpp:4016:4: error: invalid preprocessing directive #gestures_sub_dash_
   #gestures_sub_dash_->SetNumTouches(4);
    ^
/tmp/unity/unity-7.2.2+14.04.20140714/plugins/unityshell/src/unityshell.cpp:4017:4: error: invalid preprocessing directive #gestures_sub_dash_
   #gestures_sub_dash_->SetWindowId(GDK_ROOT_WINDOW());
    ^
/tmp/unity/unity-7.2.2+14.04.20140714/plugins/unityshell/src/unityshell.cpp:4018:4: error: invalid preprocessing directive #gestures_sub_dash_
   #gestures_sub_dash_->Activate();
    ^
/tmp/unity/unity-7.2.2+14.04.20140714/plugins/unityshell/src/unityshell.cpp:4020:4: error: invalid preprocessing directive #gestures_sub_windows_
   #gestures_sub_windows_.reset(new nux::GesturesSubscription);
    ^
/tmp/unity/unity-7.2.2+14.04.20140714/plugins/unityshell/src/unityshell.cpp:4021:4: error: invalid preprocessing directive #gestures_sub_windows_
   #gestures_sub_windows_->SetGestureClasses(nux::TOUCH_GESTURE
    ^
/tmp/unity/unity-7.2.2+14.04.20140714/plugins/unityshell/src/unityshell.cpp:4024:4: error: invalid preprocessing directive #gestures_sub_windows_
   #gestures_sub_windows_->SetNumTouches(3);
    ^
/tmp/unity/unity-7.2.2+14.04.20140714/plugins/unityshell/src/unityshell.cpp:4025:4: error: invalid preprocessing directive #gestures_sub_windows_
   #gestures_sub_windows_->SetWindowId(GDK_ROOT_WINDOW());
    ^
/tmp/unity/unity-7.2.2+14.04.20140714/plugins/unityshell/src/unityshell.cpp:4026:4: error: invalid preprocessing directive #gestures_sub_windows_
   #gestures_sub_windows_->Activate();
    ^
/tmp/unity/unity-7.2.2+14.04.20140714/plugins/unityshell/src/unityshell.cpp:4004:1: error: expected unqualified-id before ‘{’ token
 {
 ^
cc1plus: error: unrecognized command line option "-Wno-unused-private-field" [-Werror]
cc1plus: all warnings being treated as errors
make[3]: *** [plugins/unityshell/CMakeFiles/unityshell.dir/src/unityshell.cpp.o] Error 1
make[3]: Leaving directory `/tmp/unity/unity-7.2.2+14.04.20140714/obj-x86_64-linux-gnu'
make[2]: *** [plugins/unityshell/CMakeFiles/unityshell.dir/all] Error 2
make[2]: Leaving directory `/tmp/unity/unity-7.2.2+14.04.20140714/obj-x86_64-linux-gnu'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/tmp/unity/unity-7.2.2+14.04.20140714/obj-x86_64-linux-gnu'
dh_auto_build: make -j1 returned exit code 2
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.