Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I use my wifi usb stick (TP-Link TL-WN722N) on Ubuntu 14.04 I only get very low download speeds (around 3,5 Mbit/sec). When I reboot to Windows I get the full 25 Mbit/sec that my internet connection is capable of.

I have also tried Crunchbang 11 Waldof, but there too I only get 3,5 Mbit/sec download from the wifi usb stick.

Also, I am not the only one with that problem: http://www.techques.com/question/24-111214/Slow-Wireless-With-TP-Link-TL-WN722N-Wireless-USB-Adapter Slow wifi download speed with a TP Link tl-wn722n

The only thing that people are suggesting is disabling hwcrypt: echo "options ath9k_htc nohwcrypt=1" | sudo tee /etc/modprobe.d/ath9k.conf However, that doesn't change anything for me.

Could this be a bug in the ath9k driver or the firmware (htc_9271.fw)?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

All right, looks like I found a solution: I tried using laptop+TP-Link TL-WN722N with another router and suddenly the wifi stick was able to deliver the expected performance.

In the end I managed to narrow it down to a setting of my router called "WMM" (also called Wifi-Multi-Media or Wireless-Multimedia-Extensions or WME).

If I disable WMM in my router, the wifi stick delivers the expected 25 Mbits/sec that my internet connection is capable of.

However, please note that if you disable WMM/WME in your router settings your router will reduce its wifi speed to 54 Mbits/sec (IEEE 802.11g).


Summary:

On Windows the TP-Link TL-WN722N works as expected.

On Linux the TP-Link TL-WN722N only works correctly with IEEE 802.11g. If your TP-Link TL-WN722N is slow, you need to disable WMM or WME in your router settings.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.