Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

http://imgur.com/5U0iy2K

This is the error I am getting while installing VLC media player on Ubuntu 14.04 LTS, kindly help me with it, because I want to run my videos and audios on Ubuntu as well

share|improve this question
    
Can you open a terminal and run sudo apt-get install libtar0 libva1? –  saiarcot895 Aug 7 at 14:41
1  
Another item: Can op open a terminal and run sudo apt-get -f install and post the output of that program into your question? –  Charles Green Aug 7 at 14:46
    
I just did it, it gave the following response, "Reading package lists... Done Building dependency tree Reading state information... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. " –  Murtaza Moiz Aug 7 at 15:17
    
Response; sudo apt-get install libtar0 libva1 "Reading package lists... Done Building dependency tree Reading state information... Done Package libva1 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source Package libtar0 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'libtar0' has no installation candidate E: Package 'libva1' has no installation candidate " –  Murtaza Moiz Aug 7 at 15:19
    
I am new to this medium so will be asking loads of questions, –  Murtaza Moiz Aug 7 at 15:22

2 Answers 2

Try this:

sudo apt-get update
sudo apt-get dist-upgrade

then run:

sudo apt-get install vlc

you should get this output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  fonts-freefont-ttf libaacs0 libbasicusageenvironment0 libbluray1 libcddb2
  libcrystalhd3 libdvbpsi8 libebml4 libgnutls28 libgroupsock1 libhogweed2
  libiso9660-8 liblivemedia23 liblua5.2-0 libmatroska6 libpostproc52
  libproxy-tools libresid-builder0c2a libsdl-image1.2 libsdl1.2debian
  libsidplay2 libssh2-1 libtar0 libupnp6 libusageenvironment1 libva-x11-1
  libvcdinfo0 libvlc5 libvlccore7 libxcb-composite0 libxcb-randr0 vlc-data
  vlc-nox vlc-plugin-notify vlc-plugin-pulse
Suggested packages:
  libbluray-bdj firmware-crystalhd gnutls-bin videolan-doc
Recommended packages:
  libdvdcss2
The following NEW packages will be installed:
  fonts-freefont-ttf libaacs0 libbasicusageenvironment0 libbluray1 libcddb2
  libcrystalhd3 libdvbpsi8 libebml4 libgnutls28 libgroupsock1 libhogweed2
  libiso9660-8 liblivemedia23 liblua5.2-0 libmatroska6 libpostproc52
  libproxy-tools libresid-builder0c2a libsdl-image1.2 libsdl1.2debian
  libsidplay2 libssh2-1 libtar0 libupnp6 libusageenvironment1 libva-x11-1
  libvcdinfo0 libvlc5 libvlccore7 libxcb-composite0 libxcb-randr0 vlc vlc-data
  vlc-nox vlc-plugin-notify vlc-plugin-pulse
0 upgraded, 36 newly installed, 0 to remove and 5 not upgraded.
Need to get 14.9 MB of archives.
After this operation, 63.2 MB of additional disk space will be used.
Do you want to continue? [Y/n] 

That should get VLC installed.

If you still get an error instead, then please post back the output.

Also post the contents of your /etc/apt/sources.list.

gedit /etc/apt/sources.list

Another alternative, is to show us the content in /var/lib/apt/lists/:

open a command prompt Ctrl+Alt+T

cd /var/lib/apt/lists/
ls

Is your 14.04 install a fresh install, or was in an upgrade from a previous version of Ubuntu?

share|improve this answer
    
I removed Ubuntu 13 and installed 14.04 freshly –  Murtaza Moiz Aug 7 at 15:35
    
murtaza@murtaza-Presario-CQ57-Notebook-PC:~$ sudo apt-get install vlc Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. –  Murtaza Moiz Aug 7 at 15:37
    
The following information may help to resolve the situation: The following packages have unmet dependencies: vlc : Depends: vlc-nox (= 2.1.4-0ubuntu14.04.1) but it is not going to be installed Depends: libsdl-image1.2 (>= 1.2.10) but it is not installable Depends: libsdl1.2debian (>= 1.2.11) but it is not installable Depends: libtar0 but it is not installable Depends: libva-x11-1 (> 1.3.0~) but it is not installable Depends: libva1 (> 1.3.0~) but it is not installable Depends: libvlccore7 (>= 2.1.0) but it is not going to be installed –  Murtaza Moiz Aug 7 at 15:38
    
Depends: libxcb-composite0 but it is not installable Depends: libxcb-keysyms1 (>= 0.3.9) but it is not installable Depends: libxcb-xv0 (>= 1.2) but it is not installable Recommends: vlc-plugin-notify (= 2.1.4-0ubuntu14.04.1) but it is not going to be installed Recommends: vlc-plugin-pulse (= 2.1.4-0ubuntu14.04.1) but it is not going to be installed E: Unable to correct problems, you have held broken packages. –  Murtaza Moiz Aug 7 at 15:39
    
what is listed inside? gedit /etc/apt/sources.list –  AllGamer Aug 7 at 15:46

This worked for me assuming we are from Pakistan we might be facing the same problem

hit alt + f2 type additional drivers open the app, this will open the window software & updates go to the ubuntu software tab below change the "download from", I selected the main server. close it

hit ctrl+alt+t (open the terminal) type and enter:

sudo apt-get install vlc

download will begin if its done you can open it by typing:

vlc &

else run

sudo apt-get -f install

which I had to after that, run the

sudo apt-get install vlc

Now it installed for me again to open it you can enter

vlc &

or simply go search it in the home menu

Hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.