Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm attempting to log into my Amazon EC2 instance running Ubuntu 14.04 server edition. I'm running FreeNX. I installed FreeNX more-or-less following the instructions in the Ubuntu FreeNX documentation. I modified my /etc/nxserver/node.conf file by setting

ENABLE_PASSDB_AUTHENTICATION="1"

and adding the line

COMMAND_START_GNOME='gnome-session --session=ubuntu-2d'

which I got from this gist that I randomly found online.

I ran the following commands to enable passdb authentication for my primary user (ubuntu)

sudo nxserver --adduser ubuntu
sudo nxserver --passwd ubuntu

I installed Ubuntu desktop

apt-get install ubuntu-desktop

and a slew of other desktops based on this Ask Ubuntu post:

sudo apt-get install gnome-shell
sudo apt-get install xfce4
sudo apt-get install gnome-session-fallback

My current problem is that, although the login seems to be working, I'm getting a black screen in my NX client; I've tried both the NoMachine and OpenNX clients on my mac. If I mess with my client configuration, I can access a terminal over NX, but I can't start any desktops.

When I attempt to start using the default "gnome" configuration, I get a black screen. I can't figure out how to start any other shell. I'm most interested in getting some form of gnome working, but I'll take what I can get.

The primary question: why am I getting a black screen when attempting to connect to a gnome shell and what can I do about it?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.