Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So a couple of weeks ago my network manager icon stopped appearing; I still get automatically connected to my saved networks and the internet works fine, etc. If I go into System Settings and look at the Network settings I can still see all the networks, only the icon that's normal in the top bar is missing.

I have no idea what caused this, I don't remember installing anything. I think it just happened after a regular update.

I tried these commands to make sure I was properly up-to-date (which I found on another forum post)

sudo apt-get -f install
sudo apt-get update
sudo apt-get upgrade

That didn't do it so I found this post: Network manager indicator missing I followed the instructions in those answers;

sudo apt-get purge network-manager-gnome && sudo apt-get install network-manager-gnome

And, quoted from an answer there:

Add nm-applet to the Startup Applications (which may be found by entering "Startup Applications" in the Dash).

I restarted and then saw no Unity interface at all! So I tried those 3 commands above to update again and thankfully that fixed Unity but I still don't have my network manager.

If I try the command nm-applet in a terminal it says:

nm-applet-Message: using fallback from indicator to GtkStatusIcon

So.... I'm pretty much stumped. Any help would be appreciated.

share|improve this question
This has been an extremely annoying issue and, although I see a handful of other occurrences reported around the net, no one seems to have a good solution. I'm on the verge of doing a clean reinstall of Ubuntu over this. That's a lot of my time to backup what I need, reinstall, and then reinstall all of the apps and packages I use. Is there no way to repair this issue? – Zuko Aug 25 '14 at 1:27
up vote 6 down vote accepted

I was able to fix it by changing nm-applet to launch with dbus-launch nm-applet. To see if this will work for you, try running dbus-launch nm-applet and see if that shows up properly. To make the fix permanent, I edited /etc/xdg/autostart/nm-applet.desktop and changed



Exec=dbus-launch nm-applet
share|improve this answer
Unrelated, but my battery indicator actually ended up disappearing too... no idea why. But, because of these issues and wanting to make my Ubuntu partition much bigger, I reinstalled. (I almost never use Windows on my laptop anymore :) ) I am accepting this answer in case in helps anyone in the future, but note, I never got the chance to try it. – Zuko Dec 12 '14 at 0:44
If this is not working Try adding the dbus-launch nm-applet command as startup application. Go to Startup Applications and try add dbus-launch nm-applet command as new one. That will fixed the issue. +1 for the Answer. – ambarox Dec 22 '14 at 7:49
Nope, didn't work at all under Gnome-Shell. Received same GtkStatusIcon error. – Cerin Jan 3 '15 at 2:51

This fixed it for me

sudo apt-get install indicator-applet-complete
share|improve this answer
This method worked for me after reboot on ubuntu 15.04 – Mohammad May 18 '15 at 10:06
This worked for me after first uninstalling indiactor-applet-complete, then running this command – Matt Jul 2 '15 at 11:43

protected by Community Oct 31 '14 at 18:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.