Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Everything was just fine. I have updated Intel driver using this installer. After installing the driver it was asked to restart and I did. Now optirun is not working. Intel driver looks good I think. I run dpkg-reconfigure for bumblebee, bbswitch-dkms and nvidia-340 but nothings helps. Also restart the system couple of times. I found the following errors.

$optirun firefox
[  117.439917] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver
[  117.439954] [ERROR]Aborting because fallback start is disabled.

$dmesg | tail
[  117.506015] nvidia: Unknown symbol drm_gem_prime_handle_to_fd (err -22)
[  117.506034] nvidia: disagrees about version of symbol drm_gem_private_object_init
[  117.506036] nvidia: Unknown symbol drm_gem_private_object_init (err -22)
[  117.506106] nvidia: disagrees about version of symbol drm_gem_handle_create
[  117.506107] nvidia: Unknown symbol drm_gem_handle_create (err -22)
[  117.506161] nvidia: disagrees about version of symbol drm_pci_exit
[  117.506162] nvidia: Unknown symbol drm_pci_exit (err -22)
[  117.506187] nvidia: disagrees about version of symbol drm_gem_prime_export
[  117.506188] nvidia: Unknown symbol drm_gem_prime_export (err -22)

System information:

Ubuntu 14.04 64bit
$lspci | grep "VGA\|3D"
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
04:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev a1)

$dpkg --get-selections | grep -v deinstall | grep "bumblebee\|nvidia-\|bbswitch"
bbswitch-dkms                   install
bumblebee                   install
bumblebee-nvidia                install
nvidia-340                  install
nvidia-settings
share|improve this question
1  
It looks like the Intel driver installed an updated DRM module. Try removing the Nvidia driver and then re-installing it. If that does not work, you will need to report this as a bug to Nvidia. –  bain Aug 5 at 11:43
    
@bain How to revert back to default(14.04 default) drm?? –  shantanu Aug 5 at 17:10
    
Uninstall the Intel driver. –  bain Aug 5 at 17:25
    
@bain What should be command? What is the name of intel driver? –  shantanu Aug 5 at 17:26
    
It appears that Intel do not provide an easy way to uninstall the driver. askubuntu.com/questions/343390/… suggests using apt pinning to downgrade. –  bain Aug 5 at 17:55

1 Answer 1

up vote 1 down vote accepted

New Intel driver is the problem. Nvidia doesn't support new drm environment. To remove the new driver run the following commands:

sudo apt-get purge i915-3.15-3.13-dkms
sudo apt-get install --reinstall xserver-xorg-video-intel libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo dpkg-reconfigure xserver-xorg

Then restart the system. optirun should work after restart the system. If not then run the following commands and restart again

sudo apt-get install --reinstall nvidia-340
sudo dpkg-reconfigure bbswitch-dkms
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.