Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  no
GL npot or rect textures: no
GL vertex program:        no
GL fragment program:      no
GL vertex buffer object:  yes
GL framebuffer object:    no
GL version is 1.4+:       no

Unity supported:          no
share|improve this question
2  
What graphics solution is that? What driver is in use? Hardware acceleration is in use, yet the software/hardware combination lacks the capabilities to run Unity (and Compiz). Could be what's in the answer, or maybe you just need a different driver. –  htorque Jun 27 '11 at 5:42
add comment

2 Answers

GLX texture from pixmap is an extension that can be used to create an OpenGL texture from the contents of a X11 pixmap (such as the contents of an application window). This functionality is required to efficiently use OpenGL to render window contents to the screen (the alternative being to suck the pixel data into the window manager and then create a texture manually).

GL npot or rect textures refers to the ability to create textures of arbitrary dimensions. Earlier graphics hardware could only work with square textures whose dimensions were a power of two (e.g. 2, 4, 8, 16, 32, etc). The npot part stands for "non power of two". If you are dealing with window contents as textures, this is pretty important.

GL vertex program and GL fragment program are extensions used to program parts of the OpenGL pipeline.

GL framebuffer object is an extension to allow off screen rendering. Traditionally OpenGL operations render directly to the screen. Rendering off screen allows the resulting image to be processed further (e.g. used to create a texture for further rendering.

GL version is 1.4+ is just checking what version of OpenGL the driver claims to support. This check would be to determine whether the driver supports a minimum baseline of functionality required by that version of the specification.

share|improve this answer
add comment

It's just a suggestion and could be wrong. But probably you have a pretty old video card, which does not support the necessary openGL capabilities.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.