Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Lenovo Y570 laptop on Ubuntu 14.04. I have my settings to suspend my laptop whenever I close the lid. However my laptop doesn't suspend when I do so. It doesn't even suspend when I click on suspend (in the "Shut down" menu). I tried solution here and it seems that some of my devices are enabled:

   Device   S-state   Status   Sysfs node
  ---------------------------------------
  1. P0P1     S4    *disabled
  2. EHC1     S3    *disabled  pci:0000:00:1d.0
  3. EHC2     S3    *disabled  pci:0000:00:1a.0
  4. HDEF     S0    *disabled  pci:0000:00:1b.0
  5. RP01     S4    *disabled  pci:0000:00:1c.0
  6. PXSX     S4    *enabled   pci:0000:07:00.0
  7. RP02     S4    *disabled  pci:0000:00:1c.1
  8. PXSX     S3    *disabled  pci:0000:08:00.0
  9. RP03     S4    *disabled
  10. PXSX    S3    *disabled
  11. RP04    S3    *disabled  pci:0000:00:1c.3
  12. PXSX    S3    *enabled   pci:0000:09:00.0
  13. PXSX    S5    *disabled  pci:0000:0a:00.0
  14. RP06    S4    *disabled
  15. PXSX    S3    *disabled
  16. RP07    S4    *disabled
  17. PXSX    S3    *disabled
  18. RP08    S4    *disabled
  19. PXSX    S3    *disabled
  20. PEG0    S4    *disabled  pci:0000:00:01.0
  21. PEGP    S4    *disabled  pci:0000:01:00.0
  22. PEG1    S4    *disabled
  23. PEG2    S4    *disabled
  24. PEG3    S4    *disabled
  25. LID0    S3    *enabled 

I saw what devices were number 6 and 12 and they are a USB and ethernet controller:

07:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57781 Gigabit Ethernet PCIe (rev 10)
09:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)

I tried to disable them using sudo acpitool -W number however I can't disaable them even as sudo. What do I do? Its a problem as I am not able to suspend my laptop and its drains the battery.

share|improve this question

closed as off-topic by bain, chaskes, Warren Hill, Tim, Eric Carvalho Aug 6 at 19:15

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – bain, chaskes, Warren Hill, Tim, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

    
This is a bug and you should report it on Launchpad. You will then be asked to try the very latest mainline kernel to verify the bug has not already been fixed. If the bug still exists, you will be asked to follow the instructions at DebuggingKernelSuspend –  bain Aug 5 at 10:16
    
Check cat /sys/kernel/debug/wakeup_sources for active_count and event_count, they should increase after a wakeup and the "name" column should tell you the source of the system wakeup event. –  bain Aug 5 at 10:50

Browse other questions tagged or ask your own question.