Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently Installed kernel 2.6.39 and also updated the AMD driver to version 11.6, however seems like it's not working. I was hoping that with this new driver AMD had support for the new kernel, but it doesn't.

When I boot using the new kernel I practically get no compositing, and everything is really ugly.

How (if possible) can I patch or else do something about this?

share|improve this question
1  
Kernel 2.6.39-2 fixed any issues i had with FGLRX. –  Uri Herrera Jun 29 '11 at 3:39
    
Is that from xorg-edgers? –  Pwnna Jun 29 '11 at 21:42
    
no, i used kernel check to download it and compile it. –  Uri Herrera Jun 29 '11 at 22:21
    
Kay. I got it working as well. I'm going to put the full solution up on ubuntu forums ubuntuforums.org/showthread.php?p=10955831#post10955831 –  Pwnna Jun 29 '11 at 22:39
    
Are you experiencing any memory issue (such as swap being used to 100% and your computer freezing even though it says you have a tonne of ram unused?) –  Pwnna Jul 16 '11 at 3:41

1 Answer 1

up vote 3 down vote accepted
+50

There is a blog entry here which states that you have to patch the new catalyst driver to make it work with 2.6.39

Full instructions can be found in that blog together with links to the source code which need to be used to patch.

EDIT: Since the original question was for Catalyst 11.5, the question has been revised for Catalyst 11.6

This forum entry gives instructions on how to compile the patches for this new catalyst version - To complete the answer, I've reproduced the answer - note - this is for 64bit - if you are using 32bit, you'll need to change the entries for "x86_64" for the 32bit equivalents. Also you will not need to install the ia32-libs library:

sudo apt-get install -y build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases
sudo apt-get install -y ia32-libs
cd ~; mkdir catalyst11.6; cd catalyst11.6
wget http://www2.ati.com/drivers/linux/ati-driver-installer-11-6-x86.x86_64.run
wget http://www.mindwerks.net/wp-content/uploads/2011/03/2.6.39_bkl.patch
wget http://www.mindwerks.net/wp-content/uploads/2011/03/no_bkl.patch
chmod +x ati-driver-installer-11-6-x86.x86_64.run
sh ./ati-driver-installer-11-6-x86.x86_64.run --extract ati
cd ati; for i in ../*.patch; do patch -p1 < $i; done
./ati-installer.sh 8.861 --buildpkg Ubuntu/natty
cd ..
rm -rf ati
sudo dpkg -i fglrx*.deb
sudo reboot
share|improve this answer
    
I applied the patch and afterwards it said there was an error when building the kernel module. –  Uri Herrera Jun 26 '11 at 21:47
    
yeah... still don't have any compositing –  Uri Herrera Jun 26 '11 at 21:51
    
I noticed that you changed the question from v11.5 to 11.6. The blog entry made clear that it was tested only to 11.5. Any reason why you cant use that tested version? –  fossfreedom Jun 26 '11 at 22:03
    
beacause on 11.5 i'm unable to apply the overscan settings for my tv, so i downloaded 11.6 shortly after i made this question, and installed it, but i still didn't have any compositing. –  Uri Herrera Jun 26 '11 at 22:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.