Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am still relatively a newbie working with Ubuntu, and my current setup is having issues. I am currently running Ubuntu 12.04 lts, 32-bit, a dual-boot system with Windows XP 64 bit, 2.9 GiB, Intel Core 2, GeForce 9600, 577.8 GB. My system often (at least 2-3 times a day) crashes and restarts. When it crashes, the mouse and the keyboard do not work, and if audio is playing it will skip for about 30 secs until the computer restarts. I've been working on the crashing problem for a while now, with little success.

In any case, at this point I would prefer to just upgrade to 14.04.1 lts to see if that helps. Update Manager is not notifying me of any new lts releases, so I am trying to upgrade via Terminal. But when I run:

sudo apt-get update
sudo apt-get dist-upgrade
sudo do-release-upgrade -d

an error occurs with the update. Here is the last bit of what the terminal says:

Ign http://archive.canonical.com trusty-proposed/partner Translation-en
...
Fetched 0 B in 0s (0 B/s)
Error during update
A problem occurred during the update. This is usually some sort of network problem, please check your network connection and retry.
W:Failed to fetch http://archive.canonical.com/ubuntu/dists/trusty-backports/partner/source/Sources
...
Restoring original system state
Aborting
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done
=== Command detached from window (Mon Aug  4 12:28:37 2014) ===
=== Command terminated with exit status 1 (Mon Aug  4 12:28:37 2014) ===

What would be the best next step after this? My internet connection is fine while browsing for solutions to the problem, so how could it be a network problem? I've tried this command a few times over the past couple of days, and I always have the same result. I've also tried sudo do-release-upgrade -p, and the results seem identical. Also, for the crashing problem, I also wonder if part of the problem is that my ubuntu system is 32 bit and my Windows XP system is 64bit. Is there a way to update to Ubuntu 14.04.1 64bit without having to do a clean install? Thanks in advance!

share|improve this question
    
I answered something similar a few days back. Have you tried the solution at this link? askubuntu.com/questions/504125/… –  amanthethy Aug 6 at 2:33
    
Though, if you're having that many issues with your system as it is, your best bet is to backup all your important files and do a fresh install of 14.04. –  amanthethy Aug 6 at 2:35
    
Thanks, amanthethy! I ended up just following your second piece of advice and doing a fresh install of 14.04. So far no problems, fingers crossed! –  ceruleandanse Aug 9 at 22:42

1 Answer 1

The package repository path doesn't exist:

http://archive.canonical.com/ubuntu/dists/trusty-backports/partner/source/Sources

you will need to edit your Apt sources.list to remove reference to that archive.canonical.com precise-backports

share|improve this answer
    
How do I do this? Please edit to include it. –  Tim Aug 19 at 21:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.