Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm not an Ubuntu expert, but I've been using it for quite some time. One of the most difficult things for me to fix are graphics/X/video driver problems. I usually just reinstall everything when there's an issue since all the data can be brought over, but this time is somewhat different.

The old nVidia GeForce 6800 card on my Dell OptiPlex 745 gave out, so my only option was to revert back to the integrated graphics, which turns out to be Intel Graphics Media Accelerator (GMA) 3000. As a result of the change, I've purged all nVidia drivers and uninstalled them. I've also installed the Intel Graphics Driver Installer and went through. However, it didn't seem like any chances were made. When booting up, I get a black screen with a thin purple border.

The only way to boot into the desktop/login screen is going through the GRUB menu (pressing Shift) and selecting the recovery mode and selecting Resume, a process that takes too long to boot. The other options on the recovery menu (like dpkg) didn't work. I suspect it is just something preventing the correct drivers from loading because it is normal through recovery mode options.

Also, I've read about the option to edit the commands by adding "nomodeset" in the boot entry on GRUB, but I'd rather not try those until the problem is identified and fixed.

Can anyone guide me into fixing this or direct me to where something like this has been solved before? Thanks in advance.

share|improve this question
    
can you connect to the internet in Grub ? –  user308564 Aug 4 at 5:25
    
Your graphics card should work. Boot a text console (add text to the grub command line) then make sure your packages are up-to-date (sudo apt-get update && apt-get dist-upgrade) and remove any /etc/X11/xorg.conf you have leftover from the previous setup. Or you could just re-install 14.04.1, which might be easier. –  bain Aug 4 at 12:46
    
@user308564 No, I can't connect to the internet in Grub. –  user312041 Aug 4 at 20:10
    
@bain packages are up-to-date. There aren't any xorg.conf leftover, but there is the xorg.conf.failsafe. Adding the text console didn't do much. Do I disable the quiet splash and uncomment the console? It might be easier to re-install. However before, I received a similar issue with the LiveUSB boot. –  user312041 Aug 4 at 20:37
    
Yes just replace "quiet splash" with "text" and Ubuntu will not start Xorg. Can you ssh in when you get the black screen? If so, check the output of dmesg and /var/log/Xorg.0.log for any errors. –  bain Aug 5 at 0:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.