Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am kinda a novice to the Whole Ubuntu thing so I'll try to explain my best here. I recently got a Lenovo E545 laptop (I love it by the way), with Windows 8. having no Idea that its impossible to dual boot windows 8 and ubuntu, I attempted to dual boot the 2 with the Install ubuntu alongside windows 8. Didn't work so I deleted the ubuntu partition and reallocated it to windows. Later I tried again, by manually making partion by selecting "Something Else". Didn't work again, removed the ubuntu partition and reallocated again. So I tried a third time, again using "something else" but I noticed something wierd, It appeared that i had been installing the boot loader on the wrong partition. I had been installing it on sda1, when it appeared it should have been on sda2, so I installed grub on sda2. See what I saw before installing Ubuntu for the third time. here http://imgur.com/OFouh7P . Tried booting, but got the normal windows boot, didnt think much of it, erased the ubuntu partion and reallocated it to windows again (can you see a pattern yet?). Didnt touch sda2 where i had installed grub. Anyhow , I tried live booting into ubuntu to do something, and it booted my disc to grub, where it gave me the option to try ubuntu or install ubuntu,neither of them worked. That wasnt the only problem, I tried to boot from a USB drive instead, and I choose f12 on startup to choose the USB but when i select the usb from the list, it just blinks and goes back to the default one time boot menu, I tried booting the usb as a FDD and a USB HDD.

So obviously putting grub on sda2 screwed something up, how can i restore it?

share|improve this question
    
when you remove a partition, partition table in HDD gets out of order, which means sda1, sda2, sda3 ... order shifts . To fix it read my answer at bottom carefully in this link askubuntu.com/questions/420778/… –  kenn Aug 4 at 9:43
    
Looks like you tried to install grub to SYSTEM_DRV which is the Microsoft System Reserved partition. That should not affect the BIOS or its ability to boot an external USB device though. Are you sure you are USB booting correctly? BIOS is set up, SecureBoot is off, USB drive is working, etc.? –  bain Aug 4 at 11:40
    
See Windows 7 + Ubuntu dual boot + UEFI BIOS for more info –  bain Aug 4 at 11:42

2 Answers 2

First of all, you can't do something to HDD that Live USB/CD stops working. Try to give it some more effort. They should work.
Next, Win8 means EFI. In EFI, it does not matter where you install grub, it anyway goes to special EFI partition. I suspect that you booted your medium in non-EFI mode when installing first time.
Read manuals on how to install Ubuntu on EFI machine. Boot your LiveCD and check it is in EFI mode prior to installing. Ubuntu has a signed GRUB binary, so you don't have to turn off SecureBoot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.