Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Skype an Google Hangouts seem to be unable to use my build-in webcam on IdeaPad Y510.

In Skype it just does not show me the option to start video conversation. But when I am going to Skype -> Options -> Video Devices, it does recognize the webcam:

Lenovo EasyCamera (/dev/video0)

I am able to see myself there.
Needless to say the checkbox Enable Skype Video is checked.

In Google Hangouts my feed from webcam is shows black screen. (in the settings it is also shows correct device)

Cheese seems to be working.

I converted from Windows to Ubuntu just recently so please excuse if I am missing some 'obvious' checks or steps before asking this question. I did lots of googling on this issue but could not find any useful solution.

UPDATE: After installing V4L2 drivers and the control panel the issue is gone for the Google Hangouts. But not for Skype...

share|improve this question
1  
You need to install the v4l2 packages to use videos in other applications. Follow this article to install v4l2: allfreeubuntu.tk/v4l2 –  Dumindu Mahawela Aug 3 at 19:10
    
@user308564 : I have followed instructions on the article provided but not all packages were found. I have installed Video4Linux CP - it works and shows the feed from webcam. but does not solve the issue with skype. BTW it fixed Google hangout issue –  Michael D. Aug 3 at 19:24

1 Answer 1

First install the Webcam drivers and needed packages:

sudo apt-get install cheese build-essential linux-headers-`uname -r` libsbigudrv2 libsbigudrv0

Then for use those videos for other applications, install v4l2:

sudo apt-get install v4l2ucp v4l2loopback-dkms v4l2loopback-source v4l2loopback-utils gem-plugin-v4l2 libpt-1.10.10-plugins-v4l2 libpt-1.11.2-plugins-v4l2 qv4l2 v4l2loopback-dkms v4l2loopback-source v4l2loopback-utils v4l2ucp dvswitch dov4l dv4l gambas2-gb-v4l gambas3-gb-v4l gem-plugin-dv4l gem-plugin-v4l2 libpt-1.10.10-plugins-v4l libpt-1.10.10-plugins-v4l2 libpt-1.11.2-plugins-v4l libpt-1.11.2-plugins-v4l2 libv4l-ruby1.8 libv4lconvert0 libvideo-capture-v4l-perl qv4l2 v4l-conf v4l-utils 
share|improve this answer
    
I am getting following when trying to install v4l2: –  Michael D. Aug 3 at 21:20
    
E: Unable to locate package libpt-1.10.10-plugins-v4l2 E: Couldn't find any package by regex 'libpt-1.10.10-plugins-v4l2' E: Unable to locate package libpt-1.11.2-plugins-v4l2 E: Couldn't find any package by regex 'libpt-1.11.2-plugins-v4l2' E: Unable to locate package gambas2-gb-v4l E: Unable to locate package libpt-1.10.10-plugins-v4l E: Couldn't find any package by regex 'libpt-1.10.10-plugins-v4l' E: Unable to locate package libpt-1.10.10-plugins-v4l2 E: Couldn't find any package by regex 'libpt-1.10.10-plugins-v4l2' –  Michael D. Aug 3 at 21:20
    
E: Unable to locate package libpt-1.11.2-plugins-v4l E: Couldn't find any package by regex 'libpt-1.11.2-plugins-v4l' E: Unable to locate package libpt-1.11.2-plugins-v4l2 E: Couldn't find any package by regex 'libpt-1.11.2-plugins-v4l2' E: Unable to locate package libv4l-ruby1.8 E: Couldn't find any package by regex 'libv4l-ruby1.8' –  Michael D. Aug 3 at 21:21
    
its ok. those packages are not in 14.04. that list made for 13.04. rdemove them and install the rest. –  Dumindu Mahawela Aug 4 at 0:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.