Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I start steam in a terminal, I get the following error messages

charlie@SteamMPL:~$ steam
rm: no se puede borrar «/home/charlie/.steam/steam»: Es un directorio
rm: no se puede borrar «/home/charlie/.steam/bin»: Es un directorio
Running Steam on ubuntu 14.04 64-bit
STEAM_RUNTIME is enabled automatically
[2014-08-03 11:50:13] Startup - updater built Jul 15 2014 18:14:26
Installing breakpad exception handler for appid(steam)/version(1405474565_client)
libGL error: failed to load driver: swrast
Looks like steam didn't shutdown cleanly, scheduling immediate update check
Installing breakpad exception handler for appid(steam)/version(1405474565_client)
[2014-08-03 11:50:14] Checking for update on startup
[2014-08-03 11:50:14] Buscando actualizaciones disponibles...
Installing breakpad exception handler for appid(steam)/version(1405474565_client)
[2014-08-03 11:50:14] Download skipped: /client/steam_client_ubuntu12 version 1405474565, installed version 1405474565
[2014-08-03 11:50:14] Nothing to do
[2014-08-03 11:50:14] Verificando instalación...
[2014-08-03 11:50:14] Performing checksum verification of executable files
[2014-08-03 11:50:15] Verification complete
Gtk-Message: Failed to load module "overlay-scrollbar"
Gtk-Message: Failed to load module "unity-gtk-module"
Installing breakpad exception handler for appid(steam)/version(1405474565_client)
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 78: saw unknown, expected number
[0803/] PAC support disabled because there is no system implementation
libGL error: failed to load driver: swrast
Error: OpenGL GLX context is not using direct rendering, which may cause performance problems.

Hardware information:

  • CPU: AMD Athlon x4 760k
  • GPU: AMD Radeon R7 250 1 GB GDDR5 (Driver: Catalyst 14.4)
  • RAM: 8 GB DDR3 1600

What can I do to circumvent this issue?

share|improve this question
Well, I guess no-one gets my bounty. I solved the problem by downgrading the proprietary NVidia driver from 340 to 304 (and possibly a combination of the below). – jpaugh May 9 at 23:48

Steam ships with it's own gcc libraries, which are outdated and do not work on distributions with newer libraries. For further information, check out:

To solve your problem on Ubuntu 14.04, close Steam and run:

rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/
rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/
rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/
rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/
rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/

On 14.10, the path changed, commands are similar:

rm ~/.steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/
rm ~/.steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/
rm ~/.steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/
rm ~/.steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/
rm ~/.steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/


rm ~/.steam/bin32/steam-runtime/amd64/lib/x86_64-linux-gnu/
rm ~/.steam/bin32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/
rm ~/.steam/bin32/steam-runtime/i386/lib/i386-linux-gnu/
rm ~/.steam/bin32/steam-runtime/i386/usr/lib/i386-linux-gnu/
rm ~/.steam/bin32/steam-runtime/i386/usr/lib/i386-linux-gnu/
share|improve this answer
Amazing answer, just one thing, instead of saying "" say "*" because there can be a different version installed. To those who did the upgrade from ubuntu 14.04 to 14.10, the steam path will stay the same for the runtime – mmm3743 Oct 24 '14 at 8:24
Does anybody know if Steam will update their package to actually run on 14.10? It's a mess right now... – Afiefh Nov 2 '14 at 21:40
It seems like removing files would be a bad solution, but this seems to work brilliantly :-p Kudos. Here's hoping Volvo fixes soon. – thirdender Dec 15 '14 at 7:54
doesnt work, whabts going on. i still get the same error – Nick Bailuc Dec 30 '14 at 5:05
Didnt help me, using 14.05 and prop nvidia driver... – aXept Feb 24 '15 at 11:38

I did the following

$ tar cjvf ~/.steam/gcc_libs_backup.tar.bz2 $(find ~/.steam | grep -e libstdc++ -e libgcc_s) && rm $(find ~/.steam | grep -e libstdc++ -e libgcc_s)

and then everything worked. If it's necessary you'll have a backup of the libraries in ~/.steam/gcc_libs_backup.tar.bz2

share|improve this answer
This is the most generic answer, FTW! But you might try find ~/.steam -name 'libstdc++*' -o -name 'libgcc_s*' instead of adding a grep. – jpaugh May 5 at 22:50
It looks like everything relevant under .steam is a symlink to something under .local/share/Steam, so I ran this command on that folder instead. It did not work, though. – jpaugh May 5 at 22:51

That same error has occured to me and the problem was with the amd driver. Try doing the following:

uninstall steam
uninstall amd driver
install steam
start steam
setup everything
install amd driver

Hope it helps

share|improve this answer
thanks for stating the most obvious solution to any software problem. Genius! – Nick Bailuc Dec 30 '14 at 5:06
So clever, indeed – Heihachi Jan 2 '15 at 17:12
In Ubuntu 13.04(or 1 version before/after) there was a bug which gave the same error message when the amd driver was installed before steam, the way to fix it, install steam before amd driver, and then install the amd driver. – mmm3743 Jan 3 '15 at 20:54

I had the same issue and couldn't resolve it, but thanks to @user22153 I was able to solve it, but with a little difference. (I created a new answer, so I could easier post the commands I used, also for future reference. :D) All creds got to @user22153.

rm ~/.steam/steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/
rm ~/.steam/steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/
rm ~/.steam/steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/
rm ~/.steam/steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/
rm ~/.steam/steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/

So, simply put, if the above mentioned code (by @user22153) doesn't work, look around until you are able to find the files.

share|improve this answer

Got this error after installing version 346.47 of the nvidia Geforce drivers on Ubuntu 14.04.2. During installation of the drivers, I got a message saying that the 32 bit compatibility libraries could not be installed, but I stupidly ignored it. Running back through the installer for the video drivers, and making sure to install those 32bit libraries fixed the issue.

share|improve this answer

protected by Community Apr 15 '15 at 0:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.