Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use the Ctrl+Alt+T shortcut to open a terminal, but I cannot see how I can get it maximized. When I start it manually, I can simply do a gnome-terminal --maximize, but that does not apply for the shortcut. Even a changing of the .desktop files did not change anything.

Any way to let the shortcut open a maximized terminal window?

I use regular Gnome 2 on Ubuntu 11.04 with no compositing effects.

share|improve this question
add comment

5 Answers 5

up vote 21 down vote accepted

In gconf-editor set the key

/apps/compiz-1/plugins/gnomecompat/screen0/options/command_terminal

to gnome-terminal --maximize

enter image description here

share|improve this answer
    
That does not seem to work. :-/ –  queueoverflow Jun 26 '11 at 22:45
    
@queueoverflow: Without further information, I assumed you are using natty with unity. So please, elaborate a little bit about your system. –  enzotib Jun 27 '11 at 7:16
2  
/desktop/gnome/applications/terminal/exec is the key that helps on my computer. –  queueoverflow Oct 11 '11 at 11:01
add comment

Just as an alternative (maybe when you are working on another computer for a short time), after the window is open, you can press Alt+Space to the open the window's context menu and X to maximize. Similarly N to minimize and C to close. Works for all other applications too.

share|improve this answer
    
I prefer, in the order, Alt-F10, Alt-F9 and Alt-F4, bypassing the window menu :) –  enzotib Jun 26 '11 at 14:32
    
I too used to :). However, Alt is on the bottom line of keys and the functions are on the top, which kinda makes the adjacent duo easier to use. Plus X, C and N are also close by :) –  Sundeep Jun 26 '11 at 14:40
    
I have set Alt+X to open my terminal, so Open + Maximize is very fast. –  Arpad Horvath Jul 22 '11 at 11:43
add comment

I am a linux newbe and am happy for your question. I did a simple tweak to my system and it worked. I see linux uses a lot of - what in my programming knowledge is referred to as persistence - which is the ability to save the state of an object.

So in order to accomplish your goal, when you open a terminal either from the application menu or by combining Ctrl + Alt + T, just make sure before you close it, it's maximized, that will guarantee you that when you open again it will be maximized.

It's simple to me and workable.

share|improve this answer
add comment

Just go to edit keyboard shortcuts in "Keyboard" Then put the command gnome-terminal --maximize to the new custom shortcut and set it to launch with Ctrl + Alt + T (click reassign when the dialog box pops up.)

share|improve this answer
add comment

Not sure if this works for Gnome2 on Ubuntu 11.04, but it does for me on Ubuntu 12.04.

  • Open a Terminal
  • Select Profile Preferences from the Edit Menu.
  • Tick Use custom default terminal size and enter a default size that is too large for the screen e.g. 240 columns and 100 rows.

Click close then open a new Terminal by clicking the icon OR pressing Ctrl + Alt + T, the new terminal window should be maximised.

This answer is based upon advice I was given here: How to make terminal start maximized?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.