Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
tar -xvfz files.tgz
gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now

This the error i got. (This file is created by tar -cvzf file.tgz file ) Moreover i can able to extract this same in another ubuntu server. I'm using AWS ec2 server. please someone help

share|improve this question
The fun is that, i created a .tgz file using in that sever, and i could extract it without any error message. – George Ulahannan Aug 2 '14 at 16:43
You can edit your question. Look for the grey edit link right below the list of tags. – saiarcot895 Aug 2 '14 at 16:58

Watch the ordering. The -f option represents the file, and it should be immediately followed by the file name. The proper command here is tar -xvzf files.tgz.

share|improve this answer
i tried that format, but result is same. i have also tried unp command, which returns same error. – George Ulahannan Aug 2 '14 at 17:01
Are you sure the file exists, and that the file is actually gzip-compressed data? Run file files.tgz to verify that the output says (at least) gzip compressed data. Also, check the file sizes on the server and your computer. – saiarcot895 Aug 2 '14 at 17:36
same issue here but my file type is DOS executable (COM) instead of gzip compressed data. What does this mean ? – svassr Aug 11 '15 at 16:25

It's a tar file. Just rename the file or directory like files.tar

and then do tar -xvzf files.tar.

It will do the trick. I also faced the same error and resolved it on AWS.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.