Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried the advice here: Puny geek including the last amendments. and here Askubuntu including the advice further down for 14.04

I am running Xubuntu 14.04 on an older system. I just upgraded the memory for what it is worth.

But none of them work. I realise this has been asked before but as no response fits my case please understand why I am posting what is a question often asked.

I can work with swap but when rebooting it seems to ignore and I have no swap again. I have amended the /etc/fstab and /etc/cryptab and /etc/initramfs-tools/conf.d/resume and nothing works.

$free -m

shows

             total       used       free     shared    buffers     cached
Mem:          2015        364       1651         10         65        145
 -/+ buffers/cache:        153       1862
Swap:            0          0          0

and

$sudo fdisk -l

shows

    Disk /dev/sdc: 123.5 GB, 123522416640 bytes
    255 heads, 63 sectors/track, 15017 cylinders, total 241254720 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x0003e24c

       Device Boot      Start         End      Blocks   Id  System
    /dev/sdc1            2048   241254399   120626176   83  Linux

    Disk /dev/sdb: 60.0 GB, 60022480896 bytes
    255 heads, 63 sectors/track, 7297 cylinders, total 117231408 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x32ae6f1f

       Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1            2048     6146047     3072000   82  Linux swap / Solaris
    /dev/sdb2   *     6148096   117229567    55540736   83  Linux

    Disk /dev/sda: 1000.2 GB, 1000170586112 bytes
    255 heads, 63 sectors/track, 121597 cylinders, total 1953458176 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x6bd593d7

       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1   *        2048  1953458175   976728064    7  HPFS/NTFS/exFAT

    Disk /dev/mapper/cryptswap1: 3145 MB, 3145728000 bytes
    255 heads, 63 sectors/track, 382 cylinders, total 6144000 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x6c9ef990

and

$cat /etc/fstab

shows

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb2 during installation
UUID=d18d8971-e86c-4c2c-8396-27e175e1a9f3 /               ext4    errors=remount-ro 0       1
# /home was on /dev/sdc1 during installation
UUID=91934cf2-27b3-4db7-9f24-0ce5bb9d0d6c /home           ext4    defaults        0       2
# swap was on /dev/sdb1 during installation
UUID=c3e7afb4-7fd8-4d1d-b270-c4097493dfa4 none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
#/dev/mapper/cryptswap1 none swap sw 0 0
# the external usb backup drive
UUID="3b8e6317-6d88-4e18-a2ac-99129ce00414" /mnt/Ext_HD_1TB     ext4    defaults 0      2
#/dev/mapper/cryptswap1 none swap sw 0 0
#/dev/mapper/cryptswap1 none swap sw 0 0

and

$sudo blkid -o full -s UUID

shows

/dev/sdc1: UUID="91934cf2-27b3-4db7-9f24-0ce5bb9d0d6c" 
/dev/sdb1: UUID="f0eea40e-af3f-4eee-9b82-9c17a557e2ef" 
/dev/sdb2: UUID="d18d8971-e86c-4c2c-8396-27e175e1a9f3" 
/dev/sda1: UUID="3b8e6317-6d88-4e18-a2ac-99129ce00414"

Short of just accepting a suboptimal system I don't know what to do.

share|improve this question
    
Please include the contents of /etc/fstab. Also, did you setup encrypted swap? If you did not, the reference to cryptswap1 could be an error/misconfiguration. –  Andrea Lazzarotto Aug 2 at 13:42
    
I'll add the content. I am not sure if I did setup encrypted swap. How do I check this. Sorry it has been a while since I installed the system. –  Jacques MALAPRADE Aug 2 at 13:52
    
The output to sudo ls -lA /home/malapradej/ | grep ecrypt is lrwxrwxrwx 1 malapradej malapradej 36 Apr 18 15:21 .ecryptfs -> /home/.ecryptfs/malapradej/.ecryptfs lrwxrwxrwx 1 malapradej malapradej 35 Apr 18 15:21 .Private -> /home/.ecryptfs/malapradej/.Private –  Jacques MALAPRADE Aug 2 at 14:08

1 Answer 1

up vote 0 down vote accepted

The problem in my case was that my home directory was encrypted, but not my swap. Most of the examples provided to fix this problem has been for cases where the swap was encrypted. In order to get it to work I followed the steps provided here Askubuntu except I did not encrypt the swap. ie the following changes:

comment out all references to /dev/mapper/cryptswap... or whatever the swap drive in named in the /etc/fstab.

and do not do the last step of encrypting the swap:

sudo ecryptfs-setup-swap

Upon reboot I get no drive not present errors. Be careful between boots as the partition names /dev/sdXX 's often change between boot sessions and don't assume swap is still named the same. This cost me the formatting of a backdrive to linux-swap as the drive name changed to what used to be the swap partition. Always check with something like sudo fdisk -l to see what the swap partition is called.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.