Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a Ubuntu newbie. I followed this tutorial to install Gnome 3 on my Ubuntu Precise Pangolin.

I was expecting a desktop like this:
http://www.gnome.org/wp-content/uploads/2010/09/window-selection-3.12.png
and I ended up with a desktop like this:
http://imgur.com/dWIIkeI Please tell me what I can do to get the desired desktop.

NB: I have dual-booted using Wubi.

share|improve this question

3 Answers 3

That looks like GNOME Classic. You should choose GNOME when selecting the session at login: (screenshot from the tutorial)
enter image description here

If you still get GNOME Classic, you can force GNOME Shell by running these commands in a terminal:

gnome-shell --replace &
disown

This will replace the current WM, send GNOME Shell to the background and detach it from the terminal so that you can close it without killing gnome-shell.

share|improve this answer
    
It IS Gnome. I didnt click on classic. –  Little Child Aug 2 at 11:28
    
@LittleChild It certainly looks like GNOME Classic. Open a terminal and run gnome-shell. –  muru Aug 2 at 11:29
    
Window manager warning: Screen 0 on display ":0.0" already has a window manager; try using the --replace option to replace the current window manager. –  Little Child Aug 2 at 11:31
    
and not only that, my Gnome option has an Ubuntu symbol next to it rather than that footprint. –  Little Child Aug 2 at 11:32
1  
@LittleChild I'll try if can get my hands on a 12.04 box (which might not be until Monday). You can perhaps edit your question to reflect the fact that using the GNOME session gives you the GNOME Classic (or fallback) session, and the gnome-shell runs fine if you start it manually. –  muru Aug 2 at 17:37

Maybe the GNOME Shell you installed isn't compatible with your current Ubuntu version, so it fallbacks to the classic mode. GNOME Shell 3.4 is officially supported by Ubuntu Precise. Although it's a bit old, it's guaranteed to be stable and usable.

First of all, remove the PPA from Software Sources.

Then, sudo apt-get update && sudo apt-get install gnome-shell

That should give you GNOME Shell 3.4. If you need 3.10 or above I think you should update your Ubuntu to 14.04.

share|improve this answer
    
How do i remove the PPA ? –  Little Child Aug 2 at 11:39
    
@LittleChild: askubuntu.com/questions/307/how-can-ppas-be-removed –  muru Aug 2 at 11:40
    
@muru so I should remove the gnome-3 ppa ? –  Little Child Aug 2 at 11:41
1  
@LittleChild that the kernel and Gnome are different projects with unrelated version numbers. They both had version 3.8 at some time, but that was coincidence. –  muru Aug 2 at 11:50
1  
@LittleChild you can use the amd64 image. The i3 is 64-bit. –  muru Aug 2 at 13:42

I think the first screenshot is what you get if you press the Super key, not the desktop. But it's been a while since I used Ubuntu Gnome.

share|improve this answer
    
Tried that also. Didnt work. –  Little Child Aug 2 at 11:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.