Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install ubuntu 14.2.16 on VirtualBox. It has installed correctly, but I was having a problem related to window size. It is not possible for me to switch ubuntu in full screen mode. I got some solution for that i.e. installing Guest Additions. But afterwords I got error: unable to mount C:program files/oracle/VirtualBox/GuestAssitions.iso For that i got one solution.(Unable to mount the CD/DVD image on the machine Sandbox) I followed all steps given by but as it says about file, it should be executable. But file I am having in my host PC is not executable. I even checked settings in file property, its type is program still not executable, its opening in text editor.

What should I do now? Even if anybody could suggest me different solution for switching it in full screen it would be really helpful.

share|improve this question
Not quite sure if you've got a Windows host and Ubuntu as the VM or the other way around. If Ubuntu is the VM, then VM run a terminal (in the VM) and make sure you install Guest Additions using "sudo". You will likely find the .ISO in /media or /mnt. Otherwise, if Windows is the VM, as you said, ensure the .exe for the Guest Additions has the execute bit set. – Bernmeister Aug 2 '14 at 14:26
Actually Windows is host and ubuntu is VM. But my real problem was with full screen size of window in VBox. I got rid of that problem by scaling window size.But resolution of ubuntu is set by default on 640x480 via built in display. Option to change resolution is not there. Can you help me out? – user3620204 Aug 2 '14 at 18:43

sudo apt-get install virtualbox-guest-x11

As of 'unable to mount' problem, you can insert C:\Program Files\Oracle\VirtualBox\VBoxGuestAdditions.iso file into virtual CD/DVD manually, and them mount /dev/cdrom device to a folder of your choice (mount /dev/cdrom /mnt/mycdfolder).

share|improve this answer
Remember that this installation needs to be performed on the guest system. This should fix the fullscreen problem and even improve performance. – BelfryGhost Feb 6 '15 at 9:25

Installing Virtualbox guest addition from terminal did the trick for me.

sudo apt-get install virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11
share|improve this answer

I'll start this off as an answer as it's more than just a comment as above...

First, ensure that you've installed Guest Additions. In the window of the guest VM, check the bottom right for a line of icons. The icon second from the right, looks like a blue egg at an angle and a green arrow to the right. If you hover your mouse over that, the tooltip will tell you if guest additions is installed. I'm sure there's another way to tell, probably from the terminal too, but I cannot find that right now.

If guest additions is not installed, then you must install it if you want do things like change the video resolution. See here for more background. As I mentioned in my comment above, remember to use sudo before any command when installing/running, which the link I gave does not use in all places.

Also, what is Ubuntu 14.2.16? The current Ubuntu release is 14.04 (I think there's a recent point release to give 14.04.1).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.