Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It's annoying to me how if a window is even a couple pixels off the right edge of my screen, when I switch to that right workspace, the system thinks that the window is there. The unity launcher bar gets hidden because of it and switching to that window keeps you on the current workspace where you can't even see the window cause it's only a couple pixels.

KDE seems to do this much better where when you switch to another workspace, the window just isn't there. But well I don't want KDE. Any way of getting that same behavior without the switch?

Edit: Chromium appears both on workspaces on the top right and bottom right

share|improve this question
    
I would really like to see this option being implemented in Unity somehow. Anything we can do to make this happens? –  JohanSJA Aug 3 '11 at 11:42
    
I just tried out Gnome shell and windows don't overlap workspaces there either. –  user1477 Sep 30 '11 at 20:34
    
This really needs to be fixed, according to me, it's a completely useless feature. Also, they should add "Show Windows" in desktop grid, like KDE does –  asymptotically Jul 9 '13 at 5:53
add comment

2 Answers

up vote 4 down vote accepted

There doesn't seem to exist an option to do that in Compiz.

You can install the CompizConfig Settings Manager (package compizconfig-settings-manager, program ccsm) and raise the Edge Resistance Distance in the Snap Window plugin options in the Window Management section:

enter image description here

This will help to prevent pushing a window outside of the screen. However, if you move the window too fast it won't be triggered, so it's no optimal solution.

Maybe this issue is worth a mail to the Ayatana mailing list? :-)

share|improve this answer
    
Perhaps this helped in the past, but as of 12.04 changing the edge resistance distance is essentially useless in preventing workspace crossover. My suggestion is to make the workspace horizontal using CCSM > General Options > Desktop Size. –  holocronweaver Jan 25 '13 at 20:21
add comment

I was very annoyed by the virtual desktops overlap "feature" of unity/compiz, too.

After many hours trying to deal with their various premature concepts, bugs and inefficiencies, (which still exist in Ubuntu 11.10), I gave them up and reverted to gnome2/metacity.

Metacity is a pretty lean and efficient window manager that separates workspaces.

share|improve this answer
1  
Virtual desktops overlapped before in Ubuntu too, at least with compiz enabled. But I've sinced moved to gnome shell, which gives you both an "accelerated" desktop as well as the non-overlapping workspaces. –  user1477 Nov 4 '11 at 19:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.