Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got a fresh install of trusty (xubuntu if that matters, I don't think it should) on a Asus X551MAV-EB01-B. My function keys for brightness don't work. Here's what I know so far:

If I pass acpi_osi= or acpi_osi=! to grub I can get the brightness and wifi keys to work (I know this because I can see the OSD for brightness change), BUT:

in /sys/class/backlight I have two items:

acpi_video0 -> ../../devices/pci0000:00/0000:00:02.0/backlight/acpi_video0
intel_backlight -> ../../devices/pci0000:00/0000:00:02.0/drm/card0/card0-eDP-1/intel_backlight

With cat I can see the brightness keys are adjusting acpi_video0/brightness and not intel_backlight/brightness.

I've also tried passng acpi_backlight=vendor to grub, and if I do that, then I end up with this :

asus-nb-wmi -> ../../devices/platform/asus-nb-wmi/backlight/asus-nb-wmi/
intel_backlight -> ../../devices/pci0000:00/0000:00:02.0/drm/card0/card0-eDP-1/intel_backlight

acpi_backlight=vendor also stops the brightness keys from responding at all.

For now, I've set up an echo in /etc/rc.local to change the brightness a few seconds after lightdm starts... but where do I go from here?

share|improve this question
    
Because in their infinite wisdom you can't PM on SO. How is trusty running so far for you? I'm leaving for a large trip and can't afford to bring any of my own expensive hardware. Was looking at laptops to bring just to sharpen some skills over some long plane flights and wanted to get your opinion on the X551MAV-EB01-B. –  advocate Nov 21 at 22:21

4 Answers 4

I had the same problem on a Dell Studio laptop, which also uses intel_backlight. While I'm not sure if this will work on Asus, I think it's worth a shot. See if the answer to this question helps.

share|improve this answer

I've been using this (self-made) script for quite some time on my NVidia card and works fine. If @TheSchwa's solution doesn't work try this.

Install the script:

  1. Open a Terminal
  2. Type: sudo apt-get install -y inotify-tools and press Enter
  3. Type: sudo nano /usr/local/bin/backlight-sync and press Enter
  4. Copy the script from this page (has been adopted for your intel card already)
  5. Paste it into the Terminal window using Ctrl+Shift+V
  6. Press: Ctrl+X
  7. Press: y
  8. Press: Enter
  9. Type: sudo chmod a+x /usr/local/bin/backlight-sync and press Enter

Test the script:

  1. In the Terminal type sudo backlight-sync and press Enter
  2. Change your screen brightness at least once to see if its working
  3. Press Ctrl+C to quit

Enable the script during boot:

  1. In the Terminal type: sudo nano /etc/rc.local and press Enter
  2. Use the arrow keys to navigate above the line that says exit 0
  3. Type: /usr/local/bin/backlight-sync &
  4. Press: Ctrl+X
  5. Press: y
  6. Press: Enter
  7. Close the Terminal window
share|improve this answer

This worked for me.

Add to /etc/rc.local

echo N | sudo tee /sys/module/video/parameters/brightness_switch_enabled

Reboot

share|improve this answer

Try video.use_native_backlight=1.

share|improve this answer
    
This doesn't work. It still adjusts brightness under acpi_video0 and not intel_backlight. –  Dr. JKL Aug 3 at 3:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.