Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded from 13.10 to 14.04 and now I have to unplug the keyboard and mouse and plug them in after the system is booted. I have a Razer Black Widow keyboard and a Corsair mouse. My system is a dual boot Ubuntu/Windows 7 - i7-4770 in a Dell XPS8700 I have no problem with Windows and the USB problem(I assume it's a USB problem) only started after this upgrade. I'm not very familiar with Linux software repairs although I've used Ubuntu for years. I'd like to continue to use it without wearing out my USB ports

share|improve this question

1 Answer 1

I was having the same problem with my XPS8700 in a dual boot with Windows 8.1. What fixed it so far was disabling acpi when booting Ubuntu.

  1. When the Grub screen appears,choose the Advanced options for Ubuntu and with the latest kernel selected press "e" on the keyboard to edit the boot options.

  2. Navigate with the arrows down to the line that starts with LINUX and just add acpi=off to the end of that line.

  3. Hit Ctrl + X or F10 to boot, and you should have your mouse and keyboard back.

  4. To make this change permanent, so you don't have to do it every time, open a terminal and type:

    sudo gedit /etc/default/grub
    

    Find the line GRUB_CMDLINE_LINUX_DEFAULT and append acpi=off so that it looks like this: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off"

    Save and close the file, then update by running this command from the terminal:

     sudo update-grub
    

It worked for me, hope it helps!!!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.