Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hello to Sun Grid Engine, UI, and package experts,

After installing Sun Grid Engine and trying to run the qmon graphic user interface, the system shows the following errors:

Warning: Cannot convert string "intro" to type Pixmap
Warning: Cannot convert string "toolbar_job" to type Pixmap
Warning: Cannot convert string "toolbar_queue" to type Pixmap
Warning: Cannot convert string "toolbar_submit" to type Pixmap
Warning: Cannot convert string "toolbar_cplx" to type Pixmap
Warning: Cannot convert string "toolbar_host" to type Pixmap
Warning: Cannot convert string "toolbar_cluster" to type Pixmap
Warning: Cannot convert string "toolbar_sched" to type Pixmap
Warning: Cannot convert string "toolbar_calendar" to type Pixmap
Warning: Cannot convert string "toolbar_user" to type Pixmap
Warning: Cannot convert string "toolbar_pe" to type Pixmap
Warning: Cannot convert string "toolbar_ckpt" to type Pixmap
Warning: Cannot convert string "toolbar_ticket" to type Pixmap
Warning: Cannot convert string "toolbar_prj" to type Pixmap
Warning: Cannot convert string "toolbar_rqs" to type Pixmap
Warning: Cannot convert string "toolbar_ar" to type Pixmap
Warning: Cannot convert string "toolbar_browser" to type Pixmap
Warning: Cannot convert string "toolbar_exit" to type Pixmap

The qmon window appears yet is small and missing the buttons that are usually there.

The Ubuntu 14.04LTS is almost a fresh install without updates. SGE qmon version installed is: 6.2u5-7.3

I did try to look for other answers. You may find a similar question issue to mine in: Sun Grid Engine's qmon -- "Cannot convert string..."

However, the answer provided by Ray regarding using Son of Grid Engine does not seem to work for me since sge_8.1.6_amd64.deb complains on dependencies - lesstif2 (>= 1:0.94.4)

I know that qmon and SGE worked well on a fresh install of Ubuntu 12.04LTS in April. Since there were no changes in the package that was last changed in February. I assume that my options are either: A: Roll back to Ubuntu 12.04LTS B: Wait until there is a fix to either Ubuntu or qmon C: Build from source code

Option C seems too time consuming. Option B depends if there is someone on this list who can fix this. Option A seems the obvious choice, yet I rather upgrade to Ubuntu 14.04LTS If possible.

I hope there is a simple fix.

Jacob

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.