Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have found this solution from a thread a while ago but its temporary fix only:

This seems to be a bug in 12.04.2. As stated in comments, a simple fix would be unloading the mouse driver and load it again like this:

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

This only keeps the touchpad working on this session. To make it permanent one can create a file like /etc/modprobe.d/psmouse.conf (you can choose the name you want, but you must keep the extension) with the following content:

options psmouse proto=imps

~~ Salem's answer to Synaptic touchpad on laptop not working

My question is how to make a permanent file like he was talking about. I don't have any idea how to do that in Ubuntu.

That answer (sudo modprobe -r psmouse && sudo modprobe psmouse proto=imps) works on my 12.04 system but after I have shut down my laptop the weird problem comes back. I don't really know how to make the solution permanent because what he said was that it is just a temporary fix.

share|improve this question
    
Cheers sir @Eliah hehe~~ –  Jdx Bro Aug 1 at 4:00

1 Answer 1

up vote 0 down vote accepted

Open a Terminal by type CTRL + ALT+T

Copy and paste this

echo "options psmouse proto=imps" | sudo tee /etc/modprobe.d/psmouse.conf

Enter your password, and you should be good to go.

share|improve this answer
    
Sir after i hit my password i don't see any progress and when i try to exit the terminal it says that there is a process running..How would i know if its done or if its really processing?Does it really takes time?Thanks~ @ElefantPhace –  Jdx Bro Aug 1 at 3:21
    
ls /etc/modprobe.d/ | grep psmouse should output psmouse.confand no it takes no time at all. What process does it say is still running? –  ElefantPhace Aug 1 at 3:25
    
here's what i did i typed the echo "options psmouse proto=imps" then it shows: options psmouse proto=imps Afterwards i typed the sudo tee /etc/modprobe.d/psmouse.conf then i entered my password then nothing follows it shows nothing and when i try to close it, it says theres still process running but i dont know which process was that says still running.. Im confused xD –  Jdx Bro Aug 1 at 3:36
    
Close that terminal and start over. Don't separate. Copy and paste it exactly as I posted –  ElefantPhace Aug 1 at 3:37
    
Alright I think its okay now. Thanks for the help sir! Cheers~ –  Jdx Bro Aug 1 at 3:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.