Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

What I'm trying to do is disable the Unity side bar (launcher) which shows by default and is on the left and use Docky instead. I want to keep all of the rest of the features of Unity (the nice integration of application menus and the top bar for instance).

share|improve this question
    
I had the same issues. Switched to Classic + docky + awn –  Capt.Nemo Jun 25 '11 at 14:18
1  
Please ask your p.s as a separate question. –  dv3500ea Jun 25 '11 at 14:23

4 Answers 4

OK, so I've installed Ubuntu 11.04 in a VM to try this out.

I will outline the steps to try and make this work as best as possible.

  • Add Unity 2D PPA so we have the latest version (we sacrifice a bit of stability for features);
  • Install Unity 2D;
  • Add Plank PPA (Docky v2);
  • Install Plank;
  • Configure the Unity 2D session so it doesn't autostart the launcher and use Compiz as the window manager;

So let's start:

First off let's add the two PPAs I mentioned before:

sudo add-apt-repository ppa:ricotz/docky
sudo add-apt-repository ppa:unity-2d-team/unity-2d-daily
sudo apt-get update

Now let's install the the packages that we need:

sudo apt-get install unity-2d plank

And one final thing we need to do is change some settings in the 2d-ubuntu.session file:

gksu gedit /usr/share/gnome-session/sessions/2d-ubuntu.session

Make it look look like this (feel free to change anything as long as you know what you're doing):

[GNOME Session]
Name=Unity-2D
Required=windowmanager;panel;filemanager;
Required-windowmanager=compiz
Required-panel=unity-2d-panel
Required-filemanager=nautilus
DefaultApps=gnome-settings-daemon;plank;
FallbackSession=classic-gnome

And that should be it. If you want to revert the changes just:

sudo apt-get remove --purge unity-2d; sudo apt-get autoremove --purge
sudo apt-get install unity-2d

P.S. In case the launcher still starts when clicking the Ubuntu logo in the top left corner issue in a terminal:

killall unity-2d-launcher
sudo mv /usr/bin/unity-2d-launcher /usr/bin/unity-2d-launcher.bak

P.P.S Any subsequent updates to unity-2d will overwrite the session file so you'll need to change it again or add you're own session (which I have no idea how to do :-S).

And that should do it, just leave a comment if you have any questions. Cheers! :)

share|improve this answer
    
I installed Unity-2D, however I can't seem to find how to configure it... I also can't configure anything with Compiz like the delay time when I press ALT-TAB –  sol Jun 25 '11 at 15:00
1  
By default the Unity 2D sessions uses metacity. Press Alt+F2 and write compiz --replace to start compiz. It should also be aded to the gconf settings. To access those settings Atl+F2 and enter gconf-editor and lok fro something like sessions in the left panel. –  kicsyromy Jun 25 '11 at 15:42
    
Great ideas here! –  chrisjlee Feb 24 '12 at 17:20

This is not a perfect solution, but it should work for you to some extent. Since you cannot disable the launcher (the unity sidebar/dock), you need to set it to hide, and remove the reveal mode shortcut. To do this, open the run dialogue alt+f2, and type about:config.

This will bring up this window: enter image description here

  • Change "Reveal mode" to None.
    enter image description here
  • Change the "Hide Launcher" option to autohide.
  • Now when you use Docky, do not set it to autohide.
  • You can always use Super key (Windows key/Command Key on Mac) to open the Unity dash if you want to.
  • NB: When you move the mouse toward the top of the screen (near the dash-button (bfb) you will still trigger the launcher Reveal Mode. There is no way around this currently.
share|improve this answer

This is not a complete solution, but you can use the Ubuntu Classic and still get the "good features of Unity" :

  • Use Ubuntu Classic while logging in.
  • Add the applet "Indicator Applet Application Menu" to your gnome-panel, and move it to the top. Change its color to something darker for a Unity like experience.
  • Move docky to the left, and switch it to panel mode (so it sticks to top left). I prefer the transparency theme. (You can use the faenza theme for squared unity-like icons)

Features you'd be missing: - Unity Quicklists (Using helpers might help a bit) - Dash, and all its fancy lenses (I tried to use slingshot but its not stable yet)

Also have you looked into the unity-netbook for natty. Its available in a ppa, and used to work fast enough for me when I used it in maverick.

Here's a screenshot for how it will look : Screenshot of Classic + gnome-panel

Take a look at the top right for the menus

share|improve this answer

What I do is

  1. Right click on desktop
  2. Select change desktop background
  3. Go into behaviour tab
  4. Turn on auto hide
  5. Select top left corner
  6. But on lowest sensitivity

This makes it basically impossible to open the unity bar. If you want to open to access the unity bar just use the super key to open the dash and it should be right there.

Ziggy :D

P.S: this will only work in Ubuntu 12.04

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.