Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

During the week I did a update through the update manager and since then my desktop graphics have stopped working properly.

I usually just quickly glance through the list of packages to be updated before pressing install and this time I notice that a component called fglrx was going to be updated. I can only speculate that this has anything to do with it. I chose to update...

After the update I did a reboot and that's when the trouble began. My system was unable to boot into high resolution mode and gave me the option to boot into low graphics mode or reconfigure. I tried the reconfigure option but it didn't do anything and after I fiddled around a bit I was able to get back to a low-res desktop.

The first thing I tried was sudo dpkg-reconfigure xserver-xorg but this seem to do nothing. It just dropped me back to the command-line without a message.

Then I checked if my hardware drivers where still enabled so I opened System / Administration / Hardware Drivers panel and after searching for available drivers it came up with an empty list. I decided to downloaded the latest ATI x86_64 drivers and did an install of those. Installation was successful and I did a reboot.

I'm currently in high-res mode but I don't seem to have any hardware acceleration. Dragging a window around the desktop is a painful process to watch. There is an aticonfig command line utility that outputs about 50 zillion options. I'm pretty sure there used to be a graphical UI version of it but I can't seem to find it anywhere in my Applications menu.

When I issue the following command: fglrxinfo I get the following output:

X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  136 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  15
  Current serial number in output stream:  15

I'm on Ubuntu 9.10 and I have an ATI Radeon 5450 video card.

Any help would be greatly appreciated.

share|improve this question
    
Try uninstalling the upstream one, and reinstalling the Ubuntu ATI driver. These also might help: help.ubuntu.com/community/RadeonDriver | help.ubuntu.com/community/BinaryDriverHowto/ATI –  NightwishFan Oct 2 '10 at 5:38
    
"Try uninstalling the upstream one". How do I do that? –  Luke Oct 2 '10 at 6:35
    
I am unsure. I have never installed ATI drivers. Is there documentation for the way you installed them manually? –  NightwishFan Oct 2 '10 at 7:16
add comment

1 Answer 1

up vote 2 down vote accepted

First do a sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.legacy, then check to make sure there is no file in /etc/X11 with the name xorg.conf, then restart X or reboot the machine. If X does not find an existing xorg.conf it will attempt to generate one, and sometimes changes in the system or a change to the video driver will cause problems with the existing xorg.conf file. Also, this is an easy thing to try and easily reverted if it does not help.

Looking around on Google, it looks like the Radeon 5450 is a somewhat old card. Cards that are more than three years old or so often get rotated out of fglrx support. Sometimes the cards become unsupported by fglrx and picked up by the "radeon" open-source driver. Sometimes there is a lag in between these things happening and you are out in the cold.

By "uninstall the upstream one" is meant to get rid of the driver you downloaded from ATI. ATI's drivers are notoriously unreliable. I see that the driver is provided in the form of a .run file. I don't see any uninstall instructions for it. You might have to parse the scripts contained in the file and go manually delete all the things it installed. I would open the file and look in it myself, but my net connection is too skinny for me to grab that 100MB file in a timely manner.

I strongly recommend that you try to use the "radeon" driver instead of fglrx. If it works and provides the features and performance you need, stick with it. Also, please read the pages linked by NightwishFan if you have not done so already.

share|improve this answer
    
Thanks for your detailed answer. It's much appreciated. I was banging my head against a brick wall and to solve the issue I upgrade to 10.04, something I wanted to avoid but hey, everything is working great now (except for some minor compiz discrepancies). –  Luke Oct 10 '10 at 20:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.