Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I installed FreeNX on my PC and when I login with my 'dev' account I get the Unity interface rather than Classic Gnome. This is odd as my last login before FreeNX was with the Classic interface. I would like to have Classic over FreeNX by default.

I do login with a 'watch iplayer' account where the Unity interface works a treat. For this reason I would prefer not to uninstall Unity.

Any ideas?

share|improve this question

5 Answers 5

up vote 19 down vote accepted

Example for nomachine's NXClient:

Under 'desktop'

select 'unix' in the first drop down menu.
select 'custom' in the second drop down menu
click 'settings' on the right of it.
choose 'Run the following command' and insert:

gnome-session --session=2d-gnome
-or-
gnome-session --session=classic-gnome

and choose the 'New virtual desktop' option.

NX Client Configuration dialogue

By default your system should have these 'sessions'

ubuntu
ubuntu-2d
2d-gnome
gnome
classic-gnome

ie, you could use gnome-session --session=ubuntu-2d for a 2d Unity session (no effects)

Session files sit under

/usr/share/gnome-session/sessions/

/usr/share/gnome-session/sessions/2d-gnome.session
/usr/share/gnome-session/sessions/ubuntu-2d.session
/usr/share/gnome-session/sessions/classic-gnome.session
/usr/share/gnome-session/sessions/gnome.session
/usr/share/gnome-session/sessions/ubuntu.session

Note: '2d-gnome' and 'classic-gnome' look the same, I don't know if they differ anywhere in partituclar.

share|improve this answer
    
@DMB - you star for writing such a good answer. I could not find that elsewhere online and certainly not so well explained. Thankyou. –  Mathew Jun 25 '11 at 16:08
1  
Note: '2d-gnome' and 'classic-gnome' look the same, I don't know if they differ anywhere in partituclar. - seems that 2d-gnome launches classic with the 2d Unity sidebar too, for this to crash and burn 'unexpectedly' shortly after session start, probably explaining why the two sessions 'look the same'. Needless to say I am on 'classic-gnome'. –  Mathew Jun 25 '11 at 16:32
    
interesting, I never managed to see that on my end ;) it probably crashes too fast, heh –  DM8 Jun 25 '11 at 17:08
    
Thanks for this, my session was failing to load with no helpful error message until I switched to ubuntu-2d. Odd that your Unity 2D is called 2d-ubuntu. I've got gdm, gnome, ubuntu, ubuntu-2d. –  Nick Dec 12 '11 at 10:52
    
These suggestions bypassed Unity but each panel opened in a separate window. Using the instructions here gave me a single window. –  Sai Charan Apr 29 '12 at 21:59

Or you can just set COMMAND_START_GNOME in /etc/nxserver/node.conf

COMMAND_START_GNOME='/usr/bin/nx-session-launcher-suid gnome-session --session=classic-gnome'
share|improve this answer

In Ubuntu 12.04 and 12.10 the name of Gnome session classic is gnome-classic and the file that you must edit is /usr/NX/etc/node.conf.

Now, to start gnome-classic, edit /usr/NX/etc/node.conf and set COMMAND_START_GNOME to:

COMMAND_START_GNOME='gnome-session --session=gnome-classic'
share|improve this answer
#!/bin/bash
#
clear
#
#
# ubuntu server 12.04 freenx install script
# 
#
#
sleep 8
sudo apt-get update
#
sudo apt-get install -y python-software-properties
#
sudo add-apt-repository ppa:freenx-team -y
#
sudo apt-get update
#
sudo apt-get install freenx -y
#
wget https://bugs.launchpad.net/freenx-server/+bug/576359/+attachment/1378450/+files/nxsetup.tar.gz
#
tar xvf nxsetup.tar.gz
#
sudo cp nxsetup /usr/lib/nx
#
sudo /usr/lib/nx/nxsetup --install
#
echo -e "\n#Use classic gnome for client sessions\nCOMMAND_START_GNOME='gnome-session --session=classic-gnome'"|sudo tee -a /etc/nxserver/node.conf
clear
#
#
#
# Done!
#
#
sleep 8
share|improve this answer
    
not sure how to post this –  chris vanover Jun 4 '12 at 0:11
3  
I've fixed the formatting (in terms of the way it appears here; I didn't change the text of the script itself). The way to post large blocks of code is to paste it into your question or answer, select it, and click the <$> icon in the AskUbuntu editing toolbar. (If you wanted to do it with pure HTML rather than markdown--which I am not recommending, unless you have a specific reason you need that--then you could enclose the text between <pre><code> and </code></pre>.) Also, you should edit your answer to include some kind of explanation for exactly what this does and how to use it. –  Eliah Kagan Jun 4 '12 at 7:09

In my case was more useful the following option

COMMAND_START_GNOME="/etc/X11/Xsession 'gnome-session --session=gnome'"

This let you run the NX client as a window and you can set the window properties directly with the NX gui.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.