Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My touchpad seems to be recognized as a mouse instead of a touchpad. I have a Dell Precision M4600, and I am running Ubuntu 11.04 64-bit.

vegard@vegard-laptop:~$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                     id=12   [slave  pointer  (2)]
⎜   ↳ ImPS/2 ALPS GlidePoint                    id=14   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Laptop_Integrated_Webcam_FHD              id=10   [slave  keyboard (3)]
    ↳ Logitech USB Receiver                     id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=15   [slave  keyboard (3)]

Even though it seems to detected properly, I do not have any Touchpad settings available in Mouse Preferences.

My problem, specifically, is that my clumsy hands touch the touchpad while I am typing, send errant clicks my way, and I'd like to disable the touchpad while typing.

share|improve this question
    
I suppose GNOME's disable while typing option doesn't work then? –  htorque Jun 25 '11 at 11:38
    
@htorque It is simply not present in Mouse Preferences. If it was there, I'd use it. –  Vegard Larsen Jun 25 '11 at 11:41

2 Answers 2

This seems to be a known bug with those ALPS touchpads (ImPS/2 ALPS GlidePoint is the entry for your touchpad).

share|improve this answer
    
This is a good explanation for why it does not work. However, I am interested in a more permanent fix besides patching drivers and compiling it myself. –  Vegard Larsen Jun 25 '11 at 11:52
    
The more permanent fix would be to wait for a kernel update for 11.04. However, I can't say how likely that will happen as it depends on the complexity/regression potential of the actual patch/fix if it gets backported or not. –  htorque Jun 25 '11 at 13:48

Download psmouse-alps-1.3: http://www.dahetral.com/public-download/alps-psmouse-dlkm-for-3-2-and-3-5/view Then (using sudo / root):

Extract the folder psmouse-alps-1.3 to /usr/source
cd to /usr/source
dkms add psmouse-alps-1.3
dkms autoinstall
rmmod psmouse && modprobe psmouse

Bam! Working multitouch! :-)

(See also https://bugs.launchpad.net/ubuntu/+source/linux/+bug/606238/) - Tested on Dell M4700, Xubuntu 12.04

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.