Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I have been dipping my toes into the awesomeness that is MAAS, but I am running into trouble.

Background:

I am trying to set up a MAAS/Juju test cluster using Virtualbox VMs on a Windows desktop. I have the cluster controller built with the initial primary interface on a bridged interface so that I can actually access the web interface, but I want to have a separate network that the controller can fully manage. To this end, I set up a NAT network where the nodes will live. The controller then got a second interface (eth1) on the NAT network.

The current problem is the TFTP timeouts when the node is trying to PXE boot. I chased this down to the TFTP daemon running on the wrong interface, so I need to change that. I tried changing the 'generator' value in /etc/maas/pserv.yaml [1] but that does not appear to have changed anything.

I dpkg-reconfigure on both maas-region-controller and maas-cluster-controller to update them to the correct IP, but still the TFTP listener is starting on the wrong one[2].

Is there some additional configuration file that I am missing?

thanks

[1]

##
## Provisioning Server (pserv) configuration.
##

## Where to log. This log can be rotated by sending SIGUSR1 to the
## running server.
#
# logfile: "pserv.log"
logfile: "/var/log/maas/pserv.log"

## OOPS configuration (optional).
#
oops:
  ## Directory in which to place OOPS reports.  Must not contain any files
  # or directories other than what the oops machinery creates there.
  #
  # directory:
  directory: "/var/log/maas/oops"
  # reporter:
  reporter: "maas-pserv"

## Message broker configuration (optional, not currently used).
#
broker:
  # host: "localhost"
  # port: 5673
  # username: <current user>
  # password: "test"
  # vhost: "/"

## TFTP configuration.
#
tftp:
  # The "root" setting has been replaced by "resource_root".  The old setting
  # is used one final time when upgrading a pre-14.04 cluster controller to a
  # 14.04 version.  After that upgrade, it can be removed.
  #
  # resource_root: /var/lib/maas/boot-resources/current/

  # port: 69
  ## The URL to be contacted to generate PXE configurations.
  generator: http://10.5.5.2/MAAS/api/1.0/pxeconfig/

[2]

10.5.5.2 is the interface on the NAT network (good)

10.4.2.152 is the interface on the bridged interface (bad)

from /var/log/maas/pserv.log

2014-07-31 01:42:58-0400 [-] Starting factory <HTTPClientFactory: http://10.5.5.2/MAAS/rpc/>
2014-07-31 01:42:58-0400 [-] Starting factory <HTTPClientFactory: http://10.5.5.2/MAAS/rpc/>
2014-07-31 01:42:58-0400 [HTTPPageGetter,client] Stopping factory <HTTPClientFactory: http://10.5.5.2/MAAS/rpc/>
2014-07-31 01:42:58-0400 [HTTPPageGetter,client] Stopping factory <HTTPClientFactory: http://10.5.5.2/MAAS/rpc/>
2014-07-31 01:43:05-0400 [-] TFTP starting on 69
2014-07-31 01:43:05-0400 [-] TFTP starting on 69
2014-07-31 01:43:05-0400 [-] Starting protocol <tftp.protocol.TFTP instance at 0x7f81865aa0e0>
2014-07-31 01:43:05-0400 [-] Starting protocol <tftp.protocol.TFTP instance at 0x7f81865aa0e0>
2014-07-31 01:43:05-0400 [-] TFTP Listener started at 10.4.2.152:69
2014-07-31 01:43:05-0400 [-] TFTP Listener started at 10.4.2.152:69
share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.