Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I downloaded and installed Ubuntu 14.04 LTS on my VM and found that SSH was not working. Tried following but nothing worked:

sudo apt-get install ssh

I see only openssh_client installed, I don't see openssh_server not installed.

Can you help me to install openssh_client, i tried sudo apt-get install openssh-server this gave following error:

Package openssh-server is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'openssh-server' has no installation candidate"
share|improve this question

1 Answer 1

I had the same problem it worked by following steps

  1. sudo apt-get remove openssh-client
  2. sudo apt-get update
  3. sudo apt-get install openssh-server.

Some may think that removing ssh client will break everything, which is not true. It only removes ssh client app.

ssh issue appear to be there in all Ubuntu 14 Desktop versions, and this appear to be the easiest solution.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.