Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Does Ubuntu Ubuntu 14.04.1 LTS have any OpenSSL vulnerabilities in connection with the Heartbleed bug? I downloaded the ISO today and I am installing it and I would like to know if there are any existing vulnerabilities.

share|improve this question

marked as duplicate by user4124, dobey, Eric Carvalho, Eliah Kagan, Radu Rădeanu Aug 13 at 7:45

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
My question is with regards to the latest version 14.04.1 LTS, and if this version has any vulnerabilities. –  user277078 Jul 30 at 20:42
1  
Not a difference, since 14.04 has Heartbleed fixed (14.04.1 is 14.04 with a bunch of updates applied). If you are talking about OpenSSL vulnerabilities in general, do remove the part about being in connection with Heartbleed. "Any" is a broad term and with 100% confidence I can say that any version of any reasonably large software has vulnerabilities. –  muru Jul 30 at 20:43

1 Answer 1

up vote 2 down vote accepted

As long as you perform the needed updates, Ubuntu 14.04 does not exhibit the Heartbleed bug. If you get the latest ISO, 14.04.1, you definitely have the latest versions of the packages and are OK with regards to Heartbleed.

share|improve this answer
1  
Thank you very much for this reassurance. –  user277078 Jul 31 at 13:01
    
@user277078 please accept this answer, if it was enough, by clicking on the tick next to it. –  muru Jul 31 at 13:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.