Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using awesome v3.4.15 (Never Gonna Give You Up) and (X)Ubuntu. My display manager is lightdm.

In /etc/xdg/awesome/rc.lua I've added this line to change my background to a solid color:

theme.wallpaper_cmd = { "hsetroot -solid '#000000'" }

However, my wallpaper is always set to the default blue wallpaper on a reboot - even after pressing Mod+Ctrl+r, which reloads the config file by restarting awesome.

When I execute hsetroot -solid '#000000' itself, it works like a charm. Reloading the config doesn't change anything, the background then stays the desired fixed color.

To reload my config, I've got the default command in my rc.lua:

awful.key({ modkey, "Control" }, "r", awesome.restart)

My greeting login screen, which has the same wallpaper as the default blue desktop, is specified in /etc/lightdm/lightdm-gtk-greeter-ubuntu.conf and contains a line saying where this wallpaper is stored:

[greeter]
background=/lib/plymouth/themes/xubuntu-logo/wallpaper.png
#background=#000000

I changed it from #000000 back to the default [...]/wallpaper.png, after I've found out that switching from my user to guest/other in the menu of the said greeter resulted in the wallpaper being switched to a black wallpaper - the one specified in /etc/lightdm/lightdm-gtk-greeter-ubuntu.conf.

This is weird, because why doesn't this happen, when I select my user name in the menu, but with all other accounts?

If I switch the background setting back to the default value [...]/wallpaper.png, then selecting guest/other accounts in the menu results in the wallpaper being shown. It has a minor difference, though, to the default blue wallpaper I am having trouble with getting rid off: It doesn't have the weird 6-dots logo, which can be seen here again. So it is just the raw picture, that is located at /lib/plymouth/themes/xubuntu-logo/wallpaper.png.

  1. Why doesn't my background change to black, when setting background=#000000 in /etc/lightdm/lightdm-gtk-greeter-ubuntu.conf?
  2. Where does this extra 6-dots logo come from?
  3. Why is my config not reloaded when pressing Mod+Ctrl+r, resulting in the wallpaper_cmd to be executed?
  4. Other than awesome.restart, how can I reload my awesome config to test it?
share|improve this question

2 Answers 2

I don't know the four questions I'm afraid.

Your problem is that the colour reverts on restart? And that running the command:

theme.wallpaper_cmd = { "hsetroot -solid '#000000'" }

sets it to black corectly.

Have you tried adding a .desktop file in /home/<USER>/.config/autostart?

Run these commands:

mkdir .config/autostart

(don't worry if it says mkdir: cannot create directory ‘autostart’: File exists. That means it was already there).

cd .config/autostart
touch background-setter.desktop
gedit background-setter.desktop

In the file should be the following:

[Desktop Entry]
Version=1.0
Name=Background Setter
Comment=Set background
# the sleep and extra command is to ensure it runs, and then runs again incase there is another startup program that is breaking the settings.
Exec=theme.wallpaper_cmd = { "hsetroot -solid '#000000'" }; sleep 6; theme.wallpaper_cmd = { "hsetroot -solid '#000000'" }
Terminal=false
Type=Application
Categories=Application;

Then make it executable

chmod +x background-setter.desktop

It should launch on startup.

share|improve this answer

You mention editing /etc/xdg/awesome/rc.lua. This is the global/default awesome config (which gets overwritten on updates btw). Your personal config at ~/.config/awesome/rc.lua gets used first. Edit this file and it should stick.

haven't got a clue about the rest.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.