Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install VMwareTools-8.4.6-385536.tar.gz (VMWare Tools) on the following operating system:
Ubuntu 11.04
Linux ubuntu 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:50 UTC 2011 i686 i686 i386 GNU/Linux
I am using VMPlayer version 3.1.4 - build 385536


After starting the installation I am getting the following errors:

What is the directory that contains the init scripts?
[/etc/init.d]

Error opening No such file or directory

Distribution provided drivers for Xorg X server are used.

Skipping X configuration because X drivers are not included.

Creating a new initrd boot image for the kernel.<br>
update-initramfs: Generating /boot/initrd.img-2.6.38-8-generic
Starting VMware Tools services in the virtual machine:
Switching to guest configuration:            done
Blocking file system:                        done
Guest operating system daemon:            failed
Virtual Printing daemon:                     done
Unable to start services for VMware Tools

Can somebody help in this?

share|improve this question
    
Hello, this question has no information and activity for a very long time. I am closing it for now. If by any reason you think this question is still viable or useful in anyway or that there is still a good chance it will be answered please flag it to a moderator or add a comment with the reason(s) why you want it open. Regards –  fossfreedom Feb 23 '12 at 18:47
add comment

closed as too localized by fossfreedom Feb 23 '12 at 18:47

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

I would recommend installing open-vm-tools as they are always the latest version. This usually clears up a lot of errors. The only thing is that you have to mount shared folders manually or you can edit the vmware script to do it for you (as I did). A lot of times you will get errors with VMWare tools when in fact they are actually working because sometimes the order it tries to load the modules isn't correct or it may try loading the module too early.

share|improve this answer
    
I have installed open-vm-tools now, but i cannot map by Host C and D drive under Ubuntu. Earlier with VmWare-Tools it was possible to map them under /mnt/hgfs folder. Do you know a way around? –  Ajay Jun 27 '11 at 4:52
    
I checked the VMWare website and VmPlayer 3.4 does not support Ubuntu 11.04 yet, it only supports 10.10. So,i guess that might be the issue. –  Ajay Jun 27 '11 at 8:20
    
I managed to get it working just fine (minus 3d graphics) with open vm tools. To mount them you must do mount -t vmhgfs .host:/ /mnt/hgfs. I added this to the vmware tools init script after the kernel module gets loaded, you can also do it manually once started. –  Jesus Ramos Jun 28 '11 at 0:45
    
the mount command does not understand vmhgfs type. Am i missing something else? –  Ajay Jun 28 '11 at 9:59
    
can you do modprobe vmhgfs? also do you have open vm tools installed? –  Jesus Ramos Jun 29 '11 at 7:12
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.