Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have 3 dns servers. The 2nd and 3rd dns servers are slave from the 1st or primary server. All my server are running Ubuntu Server LTS12.4.4 and I would like to upgrade them to the lastest version, which is Ubuntu Server LTS 14.04.

Therefore, I follow the upgrade procedure on the 3rd DNS server and the upgrade was successful. Then, I need to test and make sure the slave or the transfer of the dns zone file from the primary server are working. To do that, I delete one of the domain name zone file on the 3rd dns server and then run "sudo service bind9 restart". It suppose to re-create that domain name zone file and it did and I checked the log and there is no error and everything is successful.

However, when I run the "cat domain-name-zone-file" or "more domain-name-zone-file" or "vi domain-name-zone-file" or "nano domain-name-zone-file", it display binary data or the format in the domain-name-zone-file are not readable when I run the "cat, more, vi or nano" commands.

Anyone know what my issues maybe. Any help will be greatly appreciated.

share|improve this question

1 Answer 1

It's not an error, this behavior is supported by bind 9 Look at the first answer here - http://serverfault.com/questions/488092/binary-zone-file-on-bind9

share|improve this answer
    
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. –  Eliah Kagan Apr 29 at 13:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.