Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I pretty much believe (am I wrong?) that over 90% (if not over 99.9%) of Ubuntu 10.x i386 installations are run on i686 computers. So why is Ubuntu still not i686-optimized?

The only case I can imagine, when one's install modern Ubuntu on i386 machine is a low-end netbook on something like Geode CPU. So, if Canonical guys would like to support those, then why not to leave "Netbook Remix" i386 and make mainstream desktop Ubuntu i686?

share|improve this question
1  
+1 Good question. I have always wondered about this myself. –  koushik Oct 1 '10 at 21:20
add comment

2 Answers

up vote 15 down vote accepted

During the 10.10 development cycle the decision was made to drop support for i386 and i486 entirely. You can see the original specification here: https://blueprints.launchpad.net/ubuntu/+spec/foundations-m-686-compile. I believe support may have been dropped for i586 as well, although that was a bit more controversial.

Importantly, this wasn't just kernel optimizations (686-compiled kernels had been available long before), but every package in the archive.

However, the name i386 for the 32-bit version of Ubuntu still lingers around in a few places, such as in package description fields (which are built for arches "i386" and "amd64" rather than "32bit" and "64bit"). These are just cosmetic issues in technical parts of the distro, however, and for a whole host of reasons aren't worth updating.

share|improve this answer
2  
"I believe support may have been dropped for i586 as well" - I hope so. Haven't seen anyone pervert enough to Run Ubuntu 10 on Pentium-1. –  Ivan Oct 2 '10 at 16:53
add comment

New releases of Ubuntu(10.10 and above) won't work on anything older than i686. http://princessleia.com/journal/?p=2989

share|improve this answer
1  
Can you verify that? –  Marco Ceppi Oct 2 '10 at 12:56
    
But packages are still labelled with "-i386". Why if so? –  Ivan Oct 2 '10 at 16:51
2  
@Ivan:I think it is a packaging issue. –  akshatj Oct 2 '10 at 17:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.