Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Lenovo Ideapad Y570 and it has a 1 GB NVidia GT 555M graphics card (ubuntu 14.04). All I want to do is to run cudaHashcat (64 bit one) on it. When I ran it initially I got a message like error while loading shared libraries: libnvidia-ml.so.1: cannot open shared object file: No such file or directory. I thought I don't have NVIDIA drivers and that I should install them and then started my problems.

I initially went to official NVIDIA site to download drivers for my laptop and when I installed and rebooted it, my screen resolution became aweful not to mention that unity wasn't loading up. Then I removed my /etc/modprobe.d/nvidia-installer-disable-nouveau.conf file because that's what the installer said to do in case the installation fails. My resolution problem was solved but unity still didn't boot. Moreover, I was now getting the "low-graphics-mode error" so I tried every single solution at this question and it didn't help. So I went to did a sudo apt-get purge nvidia* according to instruction on this answer and rebooted. Viola! My unity was loading properly.

Ok. My resolution and unity problem was fixed but I my original goal (to run cudaHashcat) wasn't. So now I followed the instructions from the same answer and did sudo add-apt-repository ppa:xorg-edgers/ppa. Since the graphice card in my Lenovo Y570 series ins NVidia GT555M series I did sudo apt-get install nvidia-313 and it did not work and I got a message Package 'nvidia-313' has no installation candidate. So I followed instructions here to install NVidia drivers and when I ran cudaHashcat it started but I got another error saying ERROR: No NVidia compatible platform found. Oh yeah, by the way, when I rebooted my laptop after installing my drivers during my latest installation attempt, my laptop isn't loading unity (again).

I give up. My questions: How do I install graphics card drivers for my GT 555 series)? And how do I get rid of the ERROR: No NVidia compatible platform found message so that I can properly run cudaHashcat?

share|improve this question
    
Greetings; If I could make a suggestion respectfully to your question, would you mind trying to make it more brief and to the point, and leave out personal details? The question is better in this way as it will have more appeal to people who share the same core issue. –  Akiva Jul 27 at 1:32
    
Glad to hear you got xorg-edgers in and back out - that can sometimes be a little difficult. You might try the oibaf drivers (launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers), and you should make sure you have the nonfree firmware installed sudo apt-get install linux-firmware-nonfree Curious though, why does a WPA password cracker need to use advanced graphics? –  Charles Green Jul 27 at 1:49
    
@Akiva - Ok. Thanks for the suggestion. I am not sure how to do that. How do I remove personal details? Should I not be asking for my specific graphics card? –  Pervy Sage Jul 27 at 2:01
    
@CharlesGreen - Even I'm not sure. Actually, I guess what I have are few MD5 hashes. (Its a part of a online challenge, kind of a CTF). So I am trying to crack them. I tried using Cain at first but after 2 days I didn't cover all the 7 char. so trying to make use of my GPU. :) –  Pervy Sage Jul 27 at 2:05
1  
@Akiva - Fair enough. I did change the question. However, I'm not sure if I should remove the cudaHashcat part because that's how I'm testing my drivers and that's the reason I want my drivers to work. –  Pervy Sage Jul 27 at 5:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.