Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After bootstrap a environment via manual provisioning, juju give me the following output for juju status:

ERROR Unable to connect to environment "manual". 
Please check your credentials or use 'juju bootstrap' to create a new environment.

Error details:
illegal base64 data at input byte 9

And doing bootstrap again shows me:

WARNING ignoring environments.yaml: using bootstrap config in file "/home/ayrton/.juju/environments/manual.jenv"
ERROR illegal base64 data at input byte 9

The first bootstrap shows me no error, but the status crash as above and the second one output is just the base64 error.

My juju version is 1.19.4-trusty-amd64, running in trusty 64.

The bootstrap environment is a VPS with 1GB of memory, 20GB of hd and precise 64bits.

Please, let me know if I can provide any further information.

share|improve this question
    
If your environments.yaml doesn't contain any sensitive information, can you pastebin it? Also, have you tried Juju 1.20(.1)? –  Andrew Wilkins Jul 27 at 4:19

1 Answer 1

I solved by doing a sudo apt-get install dbus under my bootstrap environment.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.