Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If I have a broken upgrade, is there a way to re-run the upgrade again?

Background:

I had 12.04 LTS installed in a dual boot setup.

I wanted to upgrade to 14.04 LTS (primarily in the hope of solving a problem where sound suddenly stopped working).

I ran do-release-upgrade and my laptop shutdown in the middle of the process.

I rebooted and ran do-release-upgrade again. It finished with errors and booted into command line mode.

After trying to reinstall ubuntu-desktop, the desktop comes up but all the window decorations are black.

If I bring up a terminal it is black on black which is useless.

(I should know at this stage of my life never to do an upgrade :-)).

Update: When running from the Live USB (or whatever) I noticed that I had inadvertently upgraded to 14.10, which is not what I intended. I suspect I will just need to bit the bullet and reinstall.

Update: I deleted the old partitions and just reinstalled. (Unfortunately, the first thing I clicked on "Amazon" seg faulted. Doesn't bode well.)

share|improve this question

closed as off-topic by Braiam, karel, Luis Alvarado Jul 27 at 16:59

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Braiam, karel, Luis Alvarado
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Does sudo apt-get install -f help any? (Also, upgrades do work if the laptop doesn't shutdown in the middle.) –  saiarcot895 Jul 26 at 17:25
1  
@saiarcot895: Thanks! I ran the comment but it did little other than "0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded". (The laptop just shut itself down for reasons unknown, Also, I have upgraded many installations many times over many years and have yet to have a single upgrade to work out of the box!) –  copper.hat Jul 26 at 17:35
1  
Why the downvote? –  copper.hat Jul 27 at 8:47
    
I think it is curious that this gets so many views even though it is closed. –  copper.hat Dec 4 at 1:02

2 Answers 2

I suggest you make a live CD and reinstall it without affecting you system files.

share|improve this answer
1  
Well, when I tried the initial upgrade, it didn't offer me the choice of upgrading, just installing alongside the existing OSs (windows7 & 12.04 LTS). I am happy to try again, but suspect I will end up having to completely install again. –  copper.hat Jul 26 at 17:42
    
I think it ask for repair or re-install –  Dishank Jul 26 at 17:46
    
I have 6 mins. to go on downloading 14.04.1 LTS. Will try again shortly. –  copper.hat Jul 26 at 17:48
    
Sure. Post about the re-installation part after you downloaded it –  Dishank Jul 26 at 17:50
    
The choices I get are first Try vs. Install, I chose Install. Then the choices are * Install Ubuntu alongside them (the other OSs), * Erase disk and insatll Ubuntu (removes all files in all OSs) and * Something else. If I follow the last option, it shows me the partition table (with Windows 7 & Ubuntu). (However, I notice that the Ubuntu partition is 14.10 which is certainly not what I originally intended.) –  copper.hat Jul 26 at 18:22

If you know which packages are affected, you could try downloading them from packages.ubuntu.com and installing them manually using dpkg.

To get to a terminal, just press

CTRL + ALT + F1

share|improve this answer
    
Unfortunately I have no idea which packages are causing issue. –  copper.hat Jul 26 at 18:11
    
Will they show up when you run apt-get upgrade/dist-upgrade? –  jnuk Jul 26 at 18:14
    
No they don't, unfortunately. –  copper.hat Jul 26 at 18:17
1  
You could try installing aptitude and then running it without any parameters. It might show up there, but I'm not sure. –  jnuk Jul 26 at 18:20
1  
I tried this and it lists three packages that 'could' be upgraded but are kept in current state to avoid breaking dependencies. I am in some upgrade twilight zone, so will go and try to reinstall. Thanks for the help. –  copper.hat Jul 26 at 18:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.